1

I am currently trying to install Ubuntu 18.10 on a HP X310 headless server with no VGA port. Due to this I am unable to install directly on the machine. I have a system with similar specs and same networking chip that I am able to install on, then swap the hard drive over. This appears to work, but I cannot get the network port working. I know this because I am able to blind type 'shutdown now' and it will work.

Is there a way in netplan to force the system to update the network card on the next boot, or is there a way to blind type a command that would make netplan configured the new network port?

2

Try this...

Install the hard disk into your working server system.

Edit /etc/default/grub. Find the line, near the top, that includes "quiet splash" and add "net.ifnames=0". This will make the network devices have standard, old school, device names. Your ethernet device will almost certainly become eth0 instead of some strange variable name like ens01p01. Then do sudo update-grub. Then reboot.

Edit /etc/netplan/*.yaml and change the ethernets: device definition from ens01p01 to eth0. Then sudo netplan --debug generate and sudo netplan apply.

Reboot the computer and use ifconfig to confirm that the ethernet device is eth0. If not, you'll need to modify the .yaml file indicated earlier.

Move the hard disk to the primary server, and it should all work.

  • That worked great! After the first reboot the network port didn't show at all in ifconfig, but after edititing the *.yaml file as you suggested and rebooting it worked great. Thanks! – Daniel Dec 14 '18 at 2:06
  • @chili555 FYI... from another question that we worked on together... get ready to "pick yourself up off of the floor"... this method does work! We had never received closure on the other question. – heynnema Dec 15 '18 at 14:40
  • @chili555 FYI #2... for reference, it was askubuntu.com/questions/1089580/… – heynnema Dec 15 '18 at 14:49
  • @heynnema I am always happy to be enlightened. I hope to learn more every day. Thanks for the heads up. A very clever solution! – chili555 Dec 18 '18 at 2:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.