0

Recently started having trouble with Transmission, worked fine before. But now it just never starts downloading the torrents. I went to see if maybe it was a firewall issue so I looked in preferences and saw that it was set to 51413. I tired to test the port using the tool provided by transmission and that test came back Closed. So I went went to the CL and explicitly opened it with sudo ufw allow 51413 Here is my ufw status:

Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere                  
51413                      ALLOW       Anywhere                  
22 (v6)                    ALLOW       Anywhere (v6)             
51413 (v6)                 ALLOW       Anywhere (v6)

I go back into transmission and test the port, and it still comes back as closed.

I tried disabling the firewall altogether, no difference.

Has anyone else seen this issue? Any suggestions for further troubleshooting?

UPDATE

I let the Transmission torrent just sit there and I just noted that it started downloading. I checked my firewall rules and I saw that I was no longer explicitly opening 51413. I double checked that the port had not been changed in Transmission, it was still 51413. I tried to test the port again using Transmission and it just sits there with Testing TCP Port... and never comes back with a result.

By the way, the item I was downloading was heavily seeded.

Any ideas why Transmission would take so long (30 min) to begin a download and or ideas about the port testing flakiness?

  • 1
    It's probably not Transmission - mine is rock solid and super-fast. So it's probably not Ubuntu either. Start looking at how limiting yourself to a single open port throttles your ability to get updates from the tracker and negotiate access to other members of the swarm. – user535733 Dec 13 '18 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.