29

I am using Chromium Version 71.0.3578.80 (Official Build) on Ubuntu, running on Ubuntu 16.04 (64-bit).

This morning my WhatsApp Web tab asked me to update Chrome with the following message:

WhatsApp works with Google Chrome 36+
To use WhatsApp, update Chrome or use Mozilla Firefox, Safari, Microsoft Edge or Opera.

What should I do to get WhatsApp Web running again?

35

The problem seems to be with the User agent Chromium for Linux is using right now. It is using Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) snap Chromium/71.0.3578.80 Chrome/71.0.3578.80 Safari/537.36 which WhatsApp web is recognizing as an older User Agent which Chrome used before version 36. I have also observed that the problem is with Chromium for Linux only since on the other hand WhatsApp web seems to work perfectly under Chromium version 71.0.3578.80 on Windows which uses User agent as Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3641.0 Safari/537.36.

So, to run WhatsApp web again you need to change the User Agent. Do remember to clear all cookies and temporary data to get these working since temporary data might create problems. There are two ways to change user agent:

1. Using Chromium Settings:

  • Open New Tab and press Ctrl+Shift+I to open Developer Tools
  • Click on Hamburger menu (vertical dots) and choose More tools - Network conditions

    Enable Network Conditions

  • Go to the Network conditions tab (should appear in bottom right), disable the option Select automatically and choose Chrome - Windows from drop-down menu.

    Select other UA

  • Note: You need to perform all things again once WhatsApp web is opened in new tab or Chromium is relaunched since Settings are applied only for that Tab and aren't remembered for a particular site.


2. Using an extension:

  • Download and install User-Agent Switcher for Chrome
  • This extension doesn't have any User agents for Chrome. So, you need to add a new custom User Agent or use in-built user agents, for example, Internet Explorer/Safari/Firefox.
  • If you want to stick to "Chromium on Ubuntu" as User Agent:

    • Right Click (or two finger tap) on the extension in top bar and click on Options
    • A list will open which would look like

    Options Page

    • Click on New User-agent name. Give any name you like and as User-agent enter this Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/73.0.3683.75 Chrome/73.0.3683.75 Safari/537.36. Give group name as Chrome, in Append?, choose Replace and in Flag field enter New. Click on Add.
  • Now, click on extension in top bar and change the UA to this newly created custom UA or some other UA (if not created).

    Setting UA

  • In this case UA is applied universally to all tabs.

Once you're done with one of the above ways, open WhatsApp Web to login.

  • Change user agent string but avoid changing OS, keep linux based. It works and it avoids you problems with web apps that uses os detection – Diego Betto Dec 19 '18 at 10:48
  • @DiegoBetto Chromium doesn't have any UA as Chrome - Ubuntu/Linux in-built. Also, I've used UA of Chromium for Windows for second approach. Since in this solution we are focused on a particular site so IMO it doesn't matter if we change OS if we know about the site. – Kulfy Dec 19 '18 at 10:53
  • 4
    this works for me only if i delete cookies for web.whatsapp.com first – mnagel Dec 30 '18 at 15:43
  • I tried many solutios, and the first one was the only that really works for me, THANKS!!! by the way, why does Chrome dev tools doesnt't show none of the linux browsers in options? evil guys – Rodrigo Jan 3 at 19:33
  • @Rodrigo Actually Spoofing user agent allows developers to check how their web apps will react to different browsers on different platforms. IMO Linux have very less market share (about 2% if we consider normal users) that's it doesn't have that. You can also observe that for mobile, we have UA built in for Android and iPhone only (no Windows, Symbian phones) because of their market share. – Kulfy Jan 4 at 10:48
2

Installing a browser extension IMHO is a bit overkill.
Instead, I've changed the Chromium icon in gnome to run the browser with --user-agent option.

  • Close Chromium.

  • Customize .desktop:

    cp /var/lib/snapd/desktop/applications/chromium_chromium.desktop ~/.local/share/applications
    vim ~/.local/share/applications/chromium_chromium.desktop
    # search "/snap/bin/chromium %U",
    # replace with "/snap/bin/chromium --user-agent='Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36' %U"
    
  • Then, reload Gnome:

    • Press Alt+F2
    • Enter restart and press Enter.
  • This is awesome. Worked like magic, though I added a comment to help me out well into the future when I totally forgot I did this and can't figure out why the UA is hardcoded in the stupid shortcut. After doing this, you'll [obviously] have to drop and re-add your icon. If/when searching for the Chromium shortcut, you'll likely now [obviously] see more than one (probably two), and will have to figure out which one was just added. FYI, this even gets you past one more hurdle in getting Netflix to work. Thanks again. – Dustin Oprea May 26 at 1:30

protected by Community Feb 21 at 7:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.