0

I'm running a Ubuntu Server 16.04 and had a vsftpd Server that i setup about two months ago with a tutorial (linked HERE). today i needed to add another user with sFTP access and did it in the same way. but now no user is working.

when i want to login i get:

myuser@myuser-Pc:~$ sftp sftpuser@mydomain
sftpuser@mydomain's password: 
Connection to mydomain closed by remote host.
Connection closed

my /etc/vsftpd.conf file: https://pastebin.com/rM5rFvyk

my /etc/vsftp.userlist file:

mysftpuser
mysftpuser2

(All users are existing)

It also doesn't run when I remove the new user from the userlist The /etc/vsftp.userlist looks like that then: mysftpuser

I really need the FTP access, i hope someone here can help me.

Update

I fixed the problem. I tried if FTPs (not sFTP) is working on the users and yes it does work. But before I added the second user, sFTP also worked. Why does it not work now? (new question)

0

Make sure all users are actually system users ( added via useradd or while system installation ).

  • I've added all the users like in the tutorial I linked, so that's not the problem. thank you for the answer – LeMoonStar Dec 12 '18 at 22:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.