0

Running Ubuntu 14.04 (Trusty), I have mounted an exFAT formatted USB drive. While attempting to git clone a repo onto it, I've run into the following error:

Cloning into 'rschedule'...
error: chmod on /media/john/John/apps/rschedule/.git/config.lock 
failed: Function not implemented
fatal: could not set 'core.filemode' to 'false'

Cloning the repo onto my computer's local file system works normally. I can also otherwise access the USB drive normally (i.e. read / create files).

Any ideas as to what may be going wrong?

Additional information which is hopefully irrelevant: Ubuntu is running on a Chromebook using crouton.

Edit:

A possibly related question: How do I use 'chmod' on an NTFS (or FAT32) partition?. Unfortunately, assuming it is related, I haven't been able to figure out how to translate that question / answers to my problem.

  • Please run sudo chmod a+rwx /path/to/fvat/usb and try again! – George Udosen Dec 12 '18 at 14:34
  • @GeorgeUdosen Thanks! Unfortunately, that command results in the following error: chmod: changing permissions of '/media/john/John': Function not implemented – John Dec 12 '18 at 14:40
  • ok have a look at these: stackoverflow.com/questions/1580596/… use the git config core.fileMode false version so it's not globally set – George Udosen Dec 12 '18 at 14:42
  • @GeorgeUdosen the git directory is currently remotely hosted on gitlab. Attempting to run git config outside of a git repository is giving me a fatal: not in a git repository error – John Dec 12 '18 at 14:49
  • @GeorgeUdosen maybe I'm running into the same problem described in the "How to use 'chmod'..." question I linked to? Namely "The mode is determined by the partition's mount options (you cannot change it via chmod)." If so, I'm not sure what mount options I need in order to make things work. – John Dec 12 '18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.