0

Currently having issues with mounting a drive to a windows share via my Ubuntu 16.04 machine. Thoughts?

Sudo nano /etc/fstab

//192.168.4.12/Share/Videos /media/Plex cifs 
defaults,noauto,nofail,username=Plex,password=XX,x-system.requires=network- 
online.target,vers=3.0 0 0'

Sudo mount -a

I don't receive any errors.. Browse to /media/Plex see that the folder is highlighted but can't see any media... When I do the following I get an error

sudo mount -t cifs //192.168.4.12/Share/Videos /media/Plex

Password for root@//192.168.4.12/Share/Videos: ***************** mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

  • Have you considered doing an NFS mount of this drive on your Ubuntu 16.04 machine? If a Windows machine also uses the same partition, it can Samba mount that instead. Just a suggestion. If you insist on a Samba mount, have you checked that a Samba user has been created on the server (which you didn't mention about; what kind of machine is it?)? It uses a different set of users; you need to assign a password with smbpasswd. – Ray Dec 12 '18 at 3:42
0

so you are trying to mount windows "Video" shared folder to your linux mount point /media/Plex ? in that case the error is very clear it says as below:

Password for root@//192.168.4.12/Share/Videos: ***************** mount error(13):

You see its asking for root password , where in it should have asked for user password (user on windows) to correct this you will have to execute command like:

mount -t cifs //192.168.4.12/Share/Videos /media/Plex --verbose -o user=username 

in the above command you need to provide username of windows and when asked provide password of the windows user let us know if that helps :)

Waiting for your reply,

  • This may work but I'm looking for a permanent mount. When I do, however, use the code above I get Mount: only root can use "--options" option – Matthew Wolf Dec 12 '18 at 11:57
0

Here's what I have used:

Where MY_WIN_NAME is my windows username
      WIN_PASSWD  is my windows login password
      192.168.1.77 is the ip address of my windows box
      SHARE_NAME   is the windows share name
      /home/myacct/m edia is the mount point:                 

mount -t cifs   -o \ user=MY_WIN_NAME,password=WIN_PASSWD,rw,hard,nosetuids,noperm,sec=ntlm \
      //192.168.1.77/SHARE_NAME  \
      /home/myacct/media
  • This is all I receive with your code.mwolf@ubuntu-plex:/media/Plex$ sudo mount -a mount: /etc/fstab: parse error: ignore entry at line 13. mount: /etc/fstab: parse error: ignore entry at line 14. mount: /etc/fstab: parse error: ignore entry at line 15. mount: /etc/fstab: parse error: ignore entry at line 16. mount: /etc/fstab: parse error: ignore entry at line 17. mount: /etc/fstab: parse error: ignore entry at line 19. mount: /etc/fstab: parse error: ignore entry at line 20. mount: /etc/fstab: parse error: ignore entry at line 21. – Matthew Wolf Dec 12 '18 at 11:55
  • I'm afraid the cut and paste did not occur properly (and I didn't notice it)... all of the backslashes (i.e. ) should have been the last character on the line it occurs... so, the easiest thing to do is simply remove all of the backslashes and concatenate the entire three lines together. – TonyB Dec 16 '18 at 4:13
  • I still keep getting this error even with the changes that were made per your comment - root@ubuntu-plex:/etc# mount -a mount: /etc/fstab: parse error: ignore entry at line 12. – Matthew Wolf Jan 4 '19 at 3:08
  • Considering my instructions only consisted of 4 lines, you must have a problem elsewhere... perhaps in your /etc/fstab.... take a look at "line 12" ... or perhaps edit your original post, adding the contents of your /etc/fstab to it. Perhaps allowing someone to spot the problem. – TonyB Jan 4 '19 at 19:12
  • I got it fixed. The information you provided I guess just doesn't fit well with Ubuntu. I followed this and now my cifs is working //apollo/install_files /path/to/mnt smbfs iocharset=utf8,credentials=/path/to/.smbcredentials,gid=1234 0 0 – Matthew Wolf Jan 4 '19 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.