105

I have had significant problems with watching flash video in 64-bit Ubuntu. Does anyone know of a good way to get flash running on the platform?

  • @Braiam - this question and answers are out-of-date. An edit in the question title is needed to state that it is limited to older versions of ubuntu – user47206 Jul 12 '15 at 15:54
  • @cipricus the answers needs to be updated. The question as it's is entirely valid (through unclear) and doesn't out-date, since people will ask how to install flash so long a Adobe Flash Player is a thing. – Braiam Jul 12 '15 at 15:57
  • @Braiam -i understand your point, but an older question like that on ubuntu 11 or 12 with a definitive high-voted answer of the same era is very unlikely to get new answers. it would be useful in my opinion to change the title so as to limit the question to v.11-12 of the system so that somebody else could ask a new one on the new systems and new circumstances related to flash without risking to duplicate – user47206 Jul 12 '15 at 16:10
  • 1
    @cipricus No. That's what bounties are for: Current answers are outdated The current answer(s) are out-of-date and require revision given recent changes. If you feel that the answers are outdated, just offer a bounty. Each answer has a header that says what versions the apply for. Through, as I said before, flash is browser dependent, and the OP did not specify which browser he's using. – Braiam Jul 12 '15 at 16:12

20 Answers 20

81
+400

For 11.04 and earlier:

Are you installing it from the Ubuntu Software Center?

  1. Go to Applications->Ubuntu Software Center.
  2. Click on Canonical Partners
  3. Click the Adobe Flash Plugin 11 and click install.

Note: this is the method I use on my 64-bit Ubuntu install and it has yet to fail me.

enter image description here

  • Same here: installed the default (but proprietary) 64bit plugin and I have no issue. – Little Jawa Jul 29 '10 at 9:41
68
+200

For 11.10 and later

Start Software Center from the Launcher and search for flash

Two entries will be found. The first is the wrapper around the 32bit flash version from Adobe. The second is the 64bit flash version.

Select the second flash entry - if the following picture is seen then you have not already enabled the Canonical Partner Repository previously.

enter image description here

Click More Info

enter image description here

... and click Use this source to enable the Canonical Partner Repository

enter image description here

see the end of this answer for the bug-report

Click Install

enter image description here

Click the Install button and enter your password when prompted. Note - you must have permission to install software.

enter image description here

The installation will proceed:

enter image description here

Once complete - launch Firefox and browse to your Flash Video. Right click and confirm that the latest version of Flash has been installed correctly.

enter image description here

Note - pictures subject to change - the 64bit version has only been recently packaged in the last week before Oneiric release - One issue currently exists:

  1. https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/870835

In the interim - either use the first "Multiverse" 32bit plugin in the pictures above or use adobe-flashplugin

sudo apt-get install adobe-flashplugin
  • Two things: Firstly, the number in the brackets is the number of reviews, not the rating (as you can see, the one you've selected is lower-rated than the other one). Secondly, I'd use the other one, which is the 64bit build rather than the 32bit compatibility wrapper. – RAOF Oct 9 '11 at 23:07
  • 1
    Since I always try to be as lazy as possible, I always install the package ubuntu-restricted-extras which is a meta-package includes adobe's flash player among other useful things. This possibility existed with earlier ubuntu versions and is still working smoothly with 11.10. – Ewald Oct 9 '11 at 23:37
  • Is the bug 870835 still valid or is it all fixed now i.e. I keep my ubuntu 12.04 x64 updated = I have the latest 64 bit Flash player and not 32 bit one? – Bucic Jul 12 '12 at 20:00
  • How do I check if I have 64-bit Ubuntu? – Samir Jul 13 '13 at 14:43
  • 1
    The current 13.04 alpha version does not have an adobe-flashplugin package in the Canonical repository. Possibly related to this? There is still an flashplugin-installer package though. – Lekensteyn Jan 28 '14 at 15:11
31

This is how to install Adobe Flash Plugin for Firefox:

  1. Go to this page and select the option .tar.gz for other Linux. Download the file.
  2. Unpack the plugin tar.gz and copy the files to the appropriate location.
  3. Save the plugin tar.gz locally and note the location the file was saved to.
  4. Launch terminal and change directories to the location the file was saved to.
  5. Unpack the tar.gz file. Once unpacked you will see the following:

    • libflashplayer.so
    • /usr
  6. Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version.(Usually it is /usr/lib/mozilla/plugins/)
    For ubuntu 14.04 path is : /usr/lib/firefox/browser/plugins

  7. Copy libflashplayer.so to the appropriate browser plugins directory. At the prompt type:

    sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:

    sudo cp -r usr/* /usr
    
  9. Now restart your browser.

  • 1
    software manager was showing installed but your method finally made it work, thank you – dhaval Jun 29 '13 at 13:45
  • Did you mean copy the usr folder in the new flash player directory to /usr or copy the contents of that folder to /usr? – It's Willem May 4 '15 at 15:30
  • 1
    Also there is a README file that tells you how to do this. It is in the .tar.gz file. – It's Willem May 4 '15 at 15:31
  • I did follow your way, now I have latest version of flash player, but youtube videos are still not opening – RegarBoy Jan 31 '17 at 7:05
  • @developer Most of the Youtube videos can be played without even installing Flash (youtube.com/html5). I am not sure if your videos are not playing because of Flash or some other reason. Did you restart your browser? – ignite Jan 31 '17 at 19:09
21

Since you have stated that this is the first time you have ever used ubuntu. i would suggest that you install the package ubuntu-restricted-extras, this includes lots of useful stuff like adobe flash and codecs and MS fonts etc.

you can do this in many ways.

software centre: Click on this link:

Install via the software center

or in a terminal: type sudo apt-get install ubuntu-restricted-extras

synaptic: search for the package ubuntu-restricted-extras right click the package and select install, and then select mark. after click the apply button and it will all install.

  • will it install the best possible Flash Player for my system or are there better versions? Will it install 64 bit version? – Bucic Jul 12 '12 at 19:55
13

There is a simple solution for this problem.

Open your Firefox and go to Youtube. Click on any video. Definitely it won't play because you don't have any flash player installed. But Firefox will promote you to install missing plug-in at the top. Simply click on it and follow the procedure. After that your video will start to play. Make sure you have latest Firefox browser installed.

Or try this in your terminal

sudo apt-get install flashplugin-installer
  • 2
    this sudo apt-get install flashplugin-installer works perfectly for me – leticia Sep 5 '12 at 18:16
5

Get my Flash-Aid extension for Firefox. It will take care of downloading and installing the appropriate version for your system architecture and will also remove conflicting plugins. If you are on 64bit, it also allows to install the 64bit preview version, which renders better results than the 32bit with nspluginwrapper.

BTW, if you can't copy anything to ~/.mozilla/plugins folder, then you should check the ownership of the ~/.mozilla folder. It should allow to copy anything there. Unless of course you are referring to a system folder outside your home directory, which requires root privilege.

  • Thank you!!! These answer needs to be on the top for 12.10 – Pramod Jan 5 '13 at 13:21
  • 1
    flash-aid was removed by it's author – BЈовић Sep 12 '13 at 6:17
  • Put it back... pls – It's Willem May 4 '15 at 15:07
  • Toot bad that it was removed!... – Cristiana Nicolae Dec 27 '16 at 22:20
4

It depends on what browser you are using. Google Chrome (not Chromium) has Flash player by default.

Go to www.google.com/chrome and click download Chrome Choose 64-bit .deb (anybody reading this using 32-bit machines should select the 32-bit .deb)

When you click on the .deb file when it has downloaded it will open in the Software Centre. Now click install and when it has finished you can find the browser in Applications -> Internet.

2

Use the Ubuntu Software Center (in the Applications menu). In the text entry field (of the search box), you can search for "flash", and the results will populate one Adobe Flash plugin (note the Adobe logo). Choose that, and follow the directions to use the source.

2

Double check which "plugin" directory is being used. Had to spend a good hour one time just plowing through all the plugin directories till I found which ones my firefox was actually reading, and then ln -sed them all to point to a common one.

End of the day you might be dropping it in the wrong place.

Also start firefox from the command line, you might see errors. Example is running a x86 flash player in an x64 browser(not os) and vice versa. From the command line (%> firefox) you should see the plugin initialization log lines. (maybe try this one first :P)

Also anything in /usr/lib/... is owned by root so you would have to sudo cp libflashplayer.so /usr/lib/firefox/plugin where .../firefox/plugin points to the location of the firefox plugin directory.

  • Finding out which plugin your processes are actually using is easy: sudo lsof | grep libflashplayer – arielf Jul 11 '12 at 21:55
2

Definite fix for 64 bit Flash on 11.10

I fixed 64 bit Flash on my 11.10 systems without any wrappers. If you follow the solutions mentioned above you will still end up with the 32 bit version and wrappers.

Note: most of this can be done in a terminal as well, in that case you don't need to install Synaptic. Furthermore, it could be that just executing steps 5, 6 and 8 is enough, but I have not tested this yet.

  1. Install Synaptic (Software Center doesn't show the package you need, not in the main items and not within the technical items and not even after it's been installed)
  2. Start Synaptic and search for 'flash'
  3. Sort by installed state
  4. Remove all flash-related packages (such as flashplugin-downloader:i386, flashplugin-installer, ndiswrapper-common etc.). If there's nothing listed you probably don't have Flash installed at all. In that case, just move on to the next step.
  5. Enable the Canonical partner repository (see above posts on how to do that)
  6. Update the package list (don't count on Software Center doing this for you, it sometimes doesn't) by clicking 'Reload' in
  7. Search for 'flash' again
  8. Install the package 'adobe-flashplugin'. If it's not in the list, something went wrong with updating the package lists. Try quiting and restarting Synapic, then click on 'Reload'.

One extra package, 'adobe-flash-properties-gtk' will be installed automatically. Nothing more.

Now you will have full 64 bit Flash without any wrappers and other garbage in both Firefox and Chromium. A restart of your browser(s) is required though. If it's still not working, try a reboot (there might be some bogus reference to the old plugins somewhere).

2
sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin

Ref: http://ubuntuguide.net/install-adobe-flash-pluginfix-not-working-problem-in-ubuntu-11-10-oneiric

2

Here's what you need to do: by default, Ubuntu comes with only open source software enabled (I think that's the case, anyway).

The way you enable other stuff (like Flash, Java, and support for recording or playing MP3s, which is NOT open source) is to go in your Software Center, go in the menus (unfortunately I'm not currently on Ubuntu and can't tell you which menu) and search for Software Sources.

Click it, and you'll be brought to a window which tells Ubuntu what it's allowed to install for you. In front of you should be a list of five different "universes". What you need to do is enable the two that aren't currently enabled.

After that, it should ask you whether you want to reload your repositories, but if it doesn't, get in a command line and type

sudo apt-get update

and let it finish. Then you should be able to find flash in either the Software Center or in the command line. You could alternatively install the ubuntu-restricted-extras package, which will give you all of the three things I mentioned above.

Good luck!

  • The menu you are thinking of is the "edit" menu. – It's Willem May 4 '15 at 15:12
2

I went through as many possible suggestions as I could find in an effort to get flash to work in Chrome on my 13.10 64bit installation. Nothing worked. I finally stumbled on the Pepper Flash answer.

There are complete and well-written instructions at (link is direct)

ubuntuhandbook.org

They detail adding the repository, updating apt, installing Pepper, and modifying the chrome config. The thing that I did differently from their instructions was to change to the /etc/chromium-browser directory and issue the command

sudo gedit default

which allowed me to add a comment to the file in addition to the necessary .sh info so the last couple lines of my modded default file were:

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Hopefully this solution will work for some time.

2

Flash videos wouldn't play on a fresh Ubuntu 14.04 install, even with adobe-flashplugin from the "partner" repository — got black screen on youtube (except after having setting it to use HTML5), dailymotion, etc.. Installing freshplayerplugin (apparently a wrapper for Chrome's flash player) solved the issue :

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
  • Note that a few days ago I ran into issues and this time it was reinstalling adobe-flashplugin that helped… – Skippy le Grand Gourou Sep 12 '15 at 20:58
1

In case the

sudo apt-get install flashplugin-nonfree

does not work (like in my case and I do not know why...), you may want to give Opera as your browser a try. It is the only one that works for me.

PS: I do not want to advertise Opera a browser, it's just that this was the only solution that somehow worked for me.

  • Using another browser and giving up isn't exactly a solution ;D – Jonathan Mar 30 '15 at 19:14
  • I tried Opera, there was no flash and no way to get it – It's Willem May 4 '15 at 15:04
  • Thank you for suggesting Opera! For me, this was the only trick that worked, after trying everything I could find online. Now I can finally use and embed Tinychat chatroom on one of my blogs! I've tried everything! – Cristiana Nicolae Dec 28 '16 at 0:29
1

I've just found a solution for those who has flash working on Firefox but not on Chromium. It's based on the fact that every browser has it's own plugins directory:

  • /usr/lib/firefox-addons/plugins (for Firefox)
  • /usr/lib/chromium-browser/plugins (for Chromium)

So, the only thing you've to do is to unificate them, aka, making one the link to the other. Probably, all plugins are on Firefox plugins directory, but it isn't worth to ensure that:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

If Firefox is the one where all plugins are, do the next. If not, do the opposite:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Finally, restart Chromium so changes take effect.

Probably, it wouldn't be a bad idea to create a bug report on Chromium/Firefox package maintainers to alert about the bug and the simple solution.

1

Well I post this here, in hopes of helping someone. I'll state what was happening and how I solved it.

SETUP:
Running 12.04 from a WUBI installation.

PROBLEM:
When I searched in the Ubuntu Software Center the keyword flash, none of the options posted here appeared except ONE for a flash plugin for Mozilla. When attempting to install it, I got a dependency error.

Tried installing it through the Ubuntu Restricted Extras from Ubuntu Software Center, however the flash plugin portion of this installation did not work because of the dependency error.

Kept searching and found this command to install the plugin

sudo apt-get install flashplugin-nonfree

and ran it from the terminal.

Same dependency error with this output:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

SOLUTION:

I ran

sudo apt-get install -f 

and then

sudo apt-get update 

which I found from some other post that was trying to solve dependencies.

Then I ran

sudo apt-get install flashplugin-nonfree

and flash plugin now works on Chromium and Firefox.

1

It depends on how you are installing. is it via a tar.gz file or rpm or some other method. There are a bunch of ways to get flash.

Download link: https://get.adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

Bonus:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
0

I checked many answers on this topic in the past week. Finally I found a link with a solution that DOES work:

https://ubuntu-mate.community/t/tutorial-flash-player-for-chromium-and-firefox/3598

Basically, the answer is that it seems to be removed from all software sources and you need to download an old version and install it manually

  • Wrong conclusion. This page provides updated info about Flash on Ubuntu. – Gunnar Hjalmarsson Apr 12 '17 at 14:50
  • I also tried THAT, does not work! However, I received a private message with a link that DOES work: ubuntu-mate.community/t/… – palbeda Apr 12 '17 at 15:14
  • any way, you are right and I have adapted the post with the link I received in reaction to my earlier answer – palbeda Apr 12 '17 at 15:23
  • Good that you made it work. However, what you write makes me confused. AFAIK there is no need to download an old version of anything. – Gunnar Hjalmarsson Apr 12 '17 at 15:27
  • Well, I have been trying for the last two weeks and NONE of the repositories associated with Ubuntu seem to carry the flashplugin anymore. This is after many many hours of trying EVERYTHING I could find on the internet, the only thing that I was able to get to work in Ubuntu 16.0.4LTS.... – palbeda Apr 12 '17 at 18:59
0

Linux is not supporting Adobe Flash Player in its store anymore.Therefore you have to do it manually.

adobe flash player

This is only verified on Firefox also if you have Chrome/Chromium you don't have to install it.

There is a procedure of Manual Installation of Adobe Flash Player on Ubuntu, follow these steps :-

  1. Open this link. It will automatically suggest you a version according to your desktop environment.

  2. Select .tar.gz for Linux option as shown in below screen-shot.

    enter image description here

  3. Now click on Download Button (Select the downloading path as Downloads in your system for easy access).

  4. Now extract file by Right clicking on folder and selecting Extract Here option.

    file in downloads folder

  5. Open Terminal CTRL+ALT+T and copy below command one by one

    5.1. cd ../

    5.2. cd your-pc-name (eg; paper96)

    5.3. cd Downloads (this is the folder where you have downloaded the file in Option 3).

    5.4. cd flash_player_npapi_linux.x86_64 (Your file name may be different just copy name of file and paste it in terminal)

    5.5. sudo mv libflashplayer.so \/usr/lib/firefox-addons/plugins hit enter and thats it.

    terminal commands

  6. Now close your browser(Firefox) and Terminal.

  7. Restart Firefox and now you have Flash Player in your browser. Visit this link to verify.

    new version of flash player

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.