6

I'm running Ubuntu 18.04.1 LTS on an MSI GS65 Stealth Thin w/ a Nvidia Geforce 1070, and when I close the lid to suspend, and reopen the lid to resume, it often enters "airplane" mode and I don't see any way to turn it back on.

In the settings menu, it says "Use hardware switch to turn off". When I hit the Fn key + the airplane key above F10 on the MSI keyboard, nothing seems to happen.

Settings

In the wifi settings it's turned off, and turning the button on doesn't have any effect.

enter image description here

I tried running rfkill list all and it returned:

1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes

Any tips on how to debug/fix this?

8

I was able to workaround it using @Gibbsoft's answer in Wifi Hard Blocked After Suspend in Ubuntu on GS65.

Update /etc/default/grub with:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' quiet splash"

And now after resuming, fn + f10 takes it out of airplane mode and removes the hard block on the wifi driver.

  • This also worked on a P65 Creator (basically the same hardware) – Sean Aitken Mar 21 '19 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.