1

I have a new clean install of 18.04.01 on hardware that was running Fedora 29 just fine. I had trouble with the iommu settings causing the usb ports to not work at all. Not even mouse and keyboard. Resolved that except that the usb 3.0 ports seem cranky. I have a Kingwin dock with a 1 terrabyte drive plugged into a USB 3.0 port that works just fine. It comes up in drive folder and mounts OK and I can access the entire drive. But then I connect a Samsung 64 gig 3.0 flash drive and it comes up but I get an error "Unknown file system exfat". I tried this with a Sandisk 3.0 flash drive and got the same error. I tried both drives in the same port that the Kingwin was plugged into. Very erratic behaviour. I tried apt-get install extfat-fuse extfat-utils no errors. I rebooted but the weird behaviour continues. Any ideas?

1

The error "Unknown file system exfat" is about the file system, not about USB 3.

There are two ways to go,

  • Work around the problem by replacing the Microsoft proprietary file system exfat with another Microsoft file system, FAT32 or NTFS, or with the linux file system ext4 or with UDF.

  • Add the software necessary to manage the exfat file system. In my Lubuntu 18.04.1 LTS I have installed two program packages from the repository 'universe', which is there in installed Ubuntu systems,

    sudo apt update
    sudo apt install exfat-fuse exfat-utils
    

This AskUbuntu link will add some details about exfat and available alternatives.


Maybe there are problems with mounting the drive. In that case maybe this link may help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.