1

I just installed a fresh 18.04 and use flashback metacity. Up until now everything is working fine ... yet the desktop icons are missing for applications/links added to the desktop. See picture. How can I get/render them?

enter image description here

Edit: Accept as trustworthy when double click on icon solved it. Steps reproduced:

enter image description here

enter image description here

enter image description here

0

I can confirm this issue on clean installation of Ubuntu 18.04 LTS with GNOME Shell (default Ubuntu session), GNOME FlashBack (Metacity) and Unity sessions.

This happens even if have enabled desktop icons with

gsettings set org.gnome.desktop.background show-desktop-icons true

I have tried to add icons by dragging them from Applications menu (in GNOME FlashBack session) to the desktop.

Also I tried to copy them from /usr/share/applications (in any session) to Desktop with:

cp /usr/share/applications/*gedit.desktop ~/Desktop
chmod +x ~/Desktop/*gedit.desktop

Visually the problem looks as following:

you have wrong icon ([wrong Gedit icon[1]) instead of correct one (correct Gedit icon).

The solution is a double click on the icon and confirm its first launch by clicking on Trust and Launch:

user should confirm launching the application

The method is suitable for all GNOME-based sessions.

  • I have icons in 18.04, but not in 19.04. I think this is what I ran. gsettings set org.gnome.desktop.interface menus-have-icons true – oldfred Dec 10 '18 at 22:40
  • @oldfred thanks, but this does not help. I have this option enabled, and still do not have correct icons for applications. – N0rbert Dec 11 '18 at 6:20
  • So what solved it was to double click on each icon and accept the security warning 'Trust and launch'. See above. Not sure if it's supposed to be like that ... but for right now its fine for me. – Philipp M Dec 11 '18 at 7:26
  • Updated my answer to be more clear and useful. – N0rbert Dec 11 '18 at 10:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.