29

Whenever I switch a video in Firefox to full screen, a message appears at the top edge of the screen, that the website is full screen now.

I find this quite annoying and unnecessary as I am the one switching to full screen. Is there a way to disable this message?

41

In the Firefox address bar type about:config and hit enter, then click the I accept the risk button.

Then search for full-screen-api.warning.timeout and set its value to 0.

After this change the message is not displayed any more when switching a video to full-screen, but you still get the message when you move the cursor to the top edge of the screen.

If you want to disable the warning completely, you'd also have to change the value for full-screen-api.warning.delay to -1. This change prevents the warning from being displayed if you move the cursor to the top screen edge.

Reminder

Please be reminded that doing this might be a security risk. Take a look at , the article provided in the comments under the question by Duncan X Simpson. This site shows how an attacker could use the full screen API to fake a website to gain access to the credentials of your online-accounts. You shouldn't "click the link" on that site unless you're able to figure out what's going on behind the scene; just read.

But as the warning pops up for only three seconds by default, one could miss the warning due to looking away from the screen at that moment for some reason. For real security the warning shouldn't time out but stay on the screen until one clicks to hide it (that would be work for the firefox team).

However, 100% security never exists and as always we have to weigh security against convenience, so if you disable the warning, keep your eyes open!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.