1

I'm trying 18.04 Server with this fancy new netplan and can't get my WiFi to work. Doing it the old-fashioned way (e.g. configuring wpa_supplicant.service and using dhclient), everything is fine. But with netplan I get syslog messages saying IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready and networkctl has interface wlp2s0 as "no-carrier" and "configuring". Here's the relevant part of my 01-netcfg.yaml file:

[Edit, see update below]

What am I missing here?

Thanks in advance

Edit1, due to comments ======================

[Edit, see update below]

So chili555 seems to be wrong about IPv6, error persists even with static config. And George, the debug output looks OK to me. Also, the gateway should not be an issue right now, but yes, I use the last IP in the network...

Output of netplan --debug apply

** (generate:3281): DEBUG: 19:10:34.892: Processing input file //etc/netplan/01-netcfg.yaml..
** (generate:3281): DEBUG: 19:10:34.892: starting new processing pass
** (generate:3281): DEBUG: 19:10:34.892: wlp2s0: adding wifi AP 'MY_ESSID'
** (generate:3281): DEBUG: 19:10:34.892: enp3s0: setting default backend to 1
** (generate:3281): DEBUG: 19:10:34.892: wlp2s0: setting default backend to 1
** (generate:3281): DEBUG: 19:10:34.892: Generating output files..
** (generate:3281): DEBUG: 19:10:34.893: NetworkManager: definition enp3s0 is not for us (backend 1)
** (generate:3281): DEBUG: 19:10:34.893: wlp2s0: Creating wpa_supplicant configuration file run/netplan/wpa-wlp2s0.conf
** (generate:3281): DEBUG: 19:10:34.893: Creating wpa_supplicant service enablement link /run/systemd/system/multi-user.target.wants/netplan-wpa@wlp2s0.service
** (generate:3281): DEBUG: 19:10:34.893: NetworkManager: definition wlp2s0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:replug wlp2s0: unbinding 0000:02:00.0 from /sys/bus/pci/drivers/iwlwifi
DEBUG:replug wlp2s0: rebinding 0000:02:00.0 to /sys/bus/pci/drivers/iwlwifi
DEBUG:device enp3s0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for enp3s0

=== Edit 2 due to comments

New .yaml fragment with dhcp4/6 ABOVE addresses, even though it works fine for Ethernet. Still in networkctl: No-carrier/configuring

  wifis:
    wlp2s0:
      dhcp4: false
      dhcp6: false
      addresses:
        - 172.20.12.195/24
        - fd13:4630:2901:12::195/64
      gateway4: 172.20.12.254
      access-points:
        "MyESSID":
          password: "MyPassword"

Also, sorry, but honestly: WTF? "Watch your indentation"? Where are we, grammar school? Is it supposed to stay like this? Especially since the (alternate) installer doesn't even give me the chance to configure networking during the installation if it detects DHCP...

=== Edit 3 due to sheer frustration

Just reinstalled (maybe my manual tinkering broke something) and took the setup-generated .yaml file as a template, so now it looks like this:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp3s0:
      dhcp4: yes
  wifis:
    wlp2s0:
      dhcp4: yes
      access-points:
        "MyESSID":
          password: "MyPassword"

Still no luck, so please stop talking about the order of entries and indentation and stuff, I think it's just plain broken. At least in the alternate installer version of 18.04 server. Next stop: live-server install...

  • Move the dhcp6 entry above the addresses entry. – George Udosen Dec 9 '18 at 17:21
  • Also change that dhcp6: no to dhcp: false. I see no and false but offical doc says it's a boolean! – George Udosen Dec 9 '18 at 17:34
  • Tried that, didn't work. But I noticed that I get syslog messages WARNING:Unknown index 6 seen, reloading interface listwith the numer always increasing?? – OttoEisen Dec 9 '18 at 17:34
  • Also changed dhcp6 no to false even though it works for the Ethernet interface, still no luck – OttoEisen Dec 9 '18 at 17:39
  • 1
    What does 'iwconfig' show when this happens? 'no-carrier' / 'configuring' implies that networkd thinks based on the kernel state that the interface is not ready to pass traffic. It may be a driver bug, or there may be something else at play. Also, what is the intended resulting configuration on this network interface - static ipv4 and ipv6 with no other addresses? – slangasek Dec 10 '18 at 19:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.