0

1.I have tried creating my own .desktop files for some apps.

2.I have also tried copying the .desktop files directly from usr/share/applications but it shows the same icons for all .desktop files both on the desktop or in a folder other than /usr/share/applications.

3.Have also tried right-clicking the .desktop file and then choosing an icon from /usr/share/icons and then clicking open but no change either in that dialog box or in the icon on the desktop except that the icon= entry reflects the chosen icon. As an example this is one of the .desktop files copied directly from usr/share/applications

[Desktop Entry]
Name=uGet
GenericName=Download Manager
Comment=Download multiple URLs and apply it to one of setting/queue.
Exec=env GDK_BACKEND=x11 uget-gtk %u
Icon=uget-icon
Terminal=false
Type=Application
Categories=Network;FileTransfer;
Keywords=filetransfer;download files;download manager;

And this is what it shows link1 link2

I get the same result even if I use absolute path to some icon

[Desktop Entry]
Name=uGet
GenericName=Download Manager
Comment=Download multiple URLs and apply it to one of setting/queue.
Exec=env GDK_BACKEND=x11 uget-gtk %u
Icon=/cab_extract.png
Terminal=false
Type=Application
Categories=Network;FileTransfer;
Keywords=filetransfer;download files;download manager;

Update 1: I have made it executable using the checkbox and also using the sudo chmod +x command link3.It still shows the ugly icon.

Update 2:I ended up reinstalling Ubuntu and it shows custom icons now,so I guess something got broken while I was tweaking around using alacarte.Thanks to vanadium and George for their help.

  • So you have an icon at this / location as seen in your deaktop file /cab_extract.png? – George Udosen Dec 9 '18 at 16:42
  • @GeorgeUdosen yes,and I used the Select Custom Icon option in the Properties Dialog Box that appears in the right-click context menu of the .desktop file. – joss5673 Dec 10 '18 at 5:54
1

Let me add alittle gif to help OP as it appears OP didn't get @vanadium instructions:

enter image description here

These are the steps to making a .desktop file launchable from your dektop. Like the Origianl answer said you have to set the executable permission on that file.

  • Thanks for your effort George but I have already tried making it executable, in fact in all the screenshots that I posted,the executable checkbox is checked. – joss5673 Dec 10 '18 at 7:47
  • Oh I see sorry to hear that! – George Udosen Dec 10 '18 at 7:48
  • Is it possible that using the application named 'alacarte' to manage my Start Menu messed something up and if that is the case how can I undo the changes if it is even possible.BTW I have clicked on Restore System Configuration option in that application,but it doesn't seems to make any difference.Right now,I will be happy with just resetting it and start over again. – joss5673 Dec 10 '18 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.