1

I'm having trouble getting Redshift to dim my screen when i want it to. One problem is that it sometimes complains that it cannot fetch my location due to a geoclue2 error, so it doesn't turn on as a result. And the other one is that according to the program's opinion, i never want to adjust the colour temperature at noon (which i do, when i draw my shades and make it dark).

So i'm wondering if there is a way to have it simply turn on, adjust the colour temperature, and nothing else; no questions asked?

I've seen some other recommendations about providing your own latitude and longitude to make it "think it's night" and therefore turn on properly, but that solution is then by design not something that can stay turned on indefinitely, and as such would also require me searching for where is it night at the moment, and what the longitude is for that place.

So instead, is there an option to have it "just turn on and nothing else"?

  • 2
    If you don't find a fix, try askubuntu.com/a/1095933/248158 – DK Bose Dec 9 '18 at 4:50
  • 1
    You should provide your release of Ubuntu. Redshift was a great feature for 16.04 LTS (& older), but is no longer necessary in 18.04 (with gnome) as gnome has it's inbuilt Night Light feature which does the same thing. Do you need redshift? (ie. an older release or flavor of Ubuntu) or are looking in the wrong place (you should be configuring Night Light?) - your release of Ubuntu is important. – guiverc Dec 9 '18 at 6:04
1

Even I had that problem. Try Night Light Slider gnome extension. This will let you set your own tone. link to the above extension: extensions.gnome.org/extension/1276/night-light-slider

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.