I have tried to boot into command line in Ubuntu 18.10 using ‘sudo systemctl set-default multi-user.target’, however on reboot I get nothing...no GUI, no command line, just a black screen...now I cannot boot up at all! Is there anything I can do?

2 Answers 2


I faced the same problem. I did ctrl + alt + f2 on the keyboard as given in this question. This automatically takes one to the command line login...and from there it is easy. Adding this answer, just in case if someone got stuck and looking for an answer.

  • Saved my day! Kinda obvious thing, but I thought OS hanged rather than waiting for my commands.
    – QtRoS
    Mar 17, 2022 at 9:37

I faced this problem with 20.04 in UEFI mode (the problem not occours in BIOS Legacy mode), but, when I disabled the splash screen, I can have tty1 at boot process ends. Here is the workarround:

systemctl set-default multi-user.target && sed -i "s/GRUB_CMDLINE_LINUX_DEFAULT=\"quiet\ splash\"/GRUB_CMDLINE_LINUX_DEFAULT=\"\"/g" /etc/default/grub && update-grub

I don't like splash screens, so for me it fits perfectly!

  • What is the "systemctl set-default multi-user.target" command? That is usually the latest target. When that target is reached, everything is there. According to the OP that didn't happen.. so he never reached that target. Basically you've just cleaned the Grub command line...
    – kanehekili
    Jun 29, 2020 at 20:31
  • @kanehekili Well, the short story: I think he's intended to boot the system without GUI, but in UEFI based computers, only a blank screen apears. Ctrl + Alt + f2 works as Apricot said, but if you want the tty1 immediately after systems boot, you have to disable splash screen. Hope you understand. Jun 30, 2020 at 20:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .