0

I have an issue where the date and time is set wrong when I use Automatic Date & Time in Settings to set the time from the internet. I've attached screen shots to show what happens when I enable the feature.

This is different from Clock time is off on dual boot because:

  • I don't need to boot into Windows to see the issue, I simply need to enable Internet date/time in Ubuntu.
  • the offset is not the time zone difference, it seems seems to be fairly random and the year is decades in the future. The attached screenshot changes my date from Dec 8 2018 1:44pm to Nov 29 2039 7:45am. I suppose time zone could account for the time different itself of 6 hours (even though my offset is ether 4 or 5, depending on time of year), but not the month/day/year differences.

I've booted from a Live USB and enabled the feature and it worked fine.

I realized that I accidentally downloaded LTS (18.04) for the Live test. When I tried it for 18.10 the Settings app freezes when I click on Details. So, I'm not sure how to get to the date/time settings to test it, but it's still probably worth noting that it worked fine in the 18.04 Live environment.

I'm using a Dell XPS 9570 laptop.

How can I fix this? Or, what apps and configs are involved in this feature and how can I see if they are corrupt or just reinstall the package(s) and config file(s) to default?

Automatic Date & Time Off Automatic Date & Time Off

Automatic Date & Time On Automatic Date & Time On

  • Yes, before this issue my Ubuntu time would be off by time zone offset if I had previously booted Windows. That was easy to fix by turning the Internet time off and back on (though I always wanted to find a way to script that on login). This issue though has a varying and wild future time when I enable updates from the Internet. It seems different, but I could be wrong. – jibbers42 Dec 9 '18 at 16:29
  • @user535733 Is it possible for you to remove the suggestion that this is a duplicate? It puts a banner at the top of the question and I'm concerned people will ignore reading further and never get any answers. Thanks. – jibbers42 Dec 10 '18 at 0:29
  • Done. Good explanation of the problem. – user535733 Dec 10 '18 at 0:38
0

I never found the answer for the 18.10 install, but after upgrading to 19.04 Automatic Date & Time started working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.