4

I have been using Clementine as my main music player for a while now, and it has always perfectly matched the theme of my desktop environment (be that Gnome, Cinnamon or Xfce) until I installed the latest version of Ubuntu.

I am currently running Ubuntu Studio 18.10, and for whatever reason it isn't following the system theme. I have checked in Clementine's settings through; Tools>Preferences>Appearance and I have got 'Use the system default colour set' ticked. I understand that Xfce is a GTK desktop environment and Clementine is created using Qt but this has never been an issue with other GTK environments before.

To show you what I mean here is a picture of Clementine running next to Thunar: enter image description here

Hopefully someone knows the answer, the lighter theme Clementine is currently using just doesn't go with the rest of my system. Thank you in advance!

Edit: I can also confirm that the same thing occurs on Xubuntu 18.10

  • How is Clementine installed? Via the package repository or via snaps? (You can tell by doing snap list and seeing if Clementine is listed there, if it is it's installed by snap) – Thomas Ward Dec 8 '18 at 18:38
  • @ThomasWard I installed it via 'sudo apt install clementine'. Just in case I have double checked the snap list, and Clementine isn't on there. – AdLinux Dec 8 '18 at 21:39
3

Your Clementine looks fine to me, has a proper Qt theme. In my case it looked like Windows 95, so my solution might not work for you. As you had no answer I though this might be useful anyway.

sudo apt install qt5-style-plugins qt5ct qt4-config

The first might be already installed. The second, qt5ct, Qt5 Settings, is not for Clementine, but for other Qt applications like Qmmp, it might prove useful.

The helpful Clementine settings are to be made with Qt4 Settings (qt4-config package, runs as qtconfig) - namely selecting GUI style GTK+.

enter image description here

Reboot was needed in my case for changes to be adopted.

As I don't use a background image, it looks like this:

enter image description here


Considering the OP's answer that solved the problem in Ubuntu 19.04, but that doesn't work in previous versions: the question was initially about 18.10, I have tested in 18.04, the OP's solution is in 19.04. That may involve different modes of operation and versions of the Qt settings tools. I do not find surprising that the Qt4 settings tool, not the Qt5 one, is the one that worked in my case, given that Clementine 1.3.1 uses Qt4, namely Qt 4.8.7. The OP solved it in 19.04 with settings made in Qt5 Configuration Tool (qt5ct). I think that is because qt5ct is a newer version in the newer 19.04 Ubuntu, while mine (version 0.34 from Ubuntu 18.04) not only behaves but also looks a bit different:

enter image description here

It might be that the newer version has taken over the Qt4 options too.


Summing it up:

  • In Xubuntu 19.04 and later, use the Qt5 Settings (qt5ct), as said in the OP's answer.

  • In previous versions where the above doesn't work, like in Xubuntu 18.04 and 18.10, use the Qt4 Settings (qt4-config package, runs as qtconfig).

  • Reboot might be needed to see changes.

  • None of those packages were already installed, so I installed all three of them (I had to install the config as qt4-qtconfig). After a quick reboot Clementine is still not following the theme, however all of the text is now larger... I will mess around with the config and see if I can get it to play ball – AdLinux Mar 19 at 19:36
  • take a look unix.stackexchange.com/q/176696/341192 – cipricus Mar 19 at 20:12
0

So I have to tip my hat to @cipricus who got it almost right with the info he had. When I tried his solution on 18.10 the Qt5 Settings wouldn't load, however having tried this on Ubuntu Studio 19.04, I was able to get it to load by just installing:

sudo apt install qt5ct qt5-style-plugins

This then allowed me to run Qt5 Settings and change the style and standard dialogue to GTK2. This seems to have worked for me, however, I am concerned that it is set to GTK2 and I don't have the option to change it to GTK3.

enter image description here

Anyway here are the results with a much nicer (in my opinion) looking dark theme:

enter image description here

  • Your 19.04-specific answer (marked as definitive) is not the good one for your 18.10-specific question, as they stand now: they refer to different versions of Ubuntu with different tools and versions available for the needed purposes. (A reader confronted with your initial problem will not be able to use your definitive answer.) In order for your answer to stand as definitive, you should either edit your question and/or (even better) include a bit more complex info in your answer (see the "Summing up" part at the end of my answer) – cipricus Jul 17 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.