0

I was able (after many hours) to make a clone of my android internal filesystem using ADB on my Galaxy S6 which is not rooted, running stock ROM, and a screen that the touch functions stopped working completely.

I now have a .IMG file of the entire filesystem. My problem I can't seem to figure out how to mount/explore the image for the life of me, and Google hasn't been much help.

I have Mac OS, Ubuntu, and Windows 10 devices I can use, though I've mostly been trying to figure out a solution through Linux. So far I have tried the following with no luck:

  • Mounting as a loop drive
  • Converting to a raw.img file (simg2img) then mounting
  • Using the parted utility
  • Using the Fdisk utility
  • Using the testdisk utility
  • Writing the file to a external SD card, then tried to mount/repair.

Nothing has worked so far. I have been able to mount a few different images and have it display the file contents, but the data past the directories isn't there.

Does anyone have any idea how to do this? Any help would be appreciated.

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.