3

I recently installed Ubuntu 18.04 on my 2009 mac mini. I used a bootable flash drive and all is well. Initially, WiFi adapter where not found, but after going into the Software & Updates > Additional Drivers and installing and using the Broadcom 802.11 Linux STA wireless driver source from bcwl-kernel-source.

image of additional driver

However there are no visible WiFi networks even though there are at least three around me as my phone and laptop are connected to them.

Image of no visible WiFi networks

I have tried to reinstall the kernel, reinstall the network-manager, and dist-upgrade. Thank you for your help.

Edit

After running lspci -nnk | grep 0280 -A3 I get this for an output:

03:00.0 Network controller [0280]: Broadcom Limited BCM4321 802.11a/b/g/n [14e4:4328] (rev 05)
Subsystem: Apple Inc. AirPort Extreme [106b:0090]
Kernel driver in use: wl
Kernel modules: ssb, wl

And after running sudo iwlist chan I get:

    enp0s10   no frequency information.

lo        no frequency information.

enp0s4f1u7c4i2  no frequency information.

wlp3s0    32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 14 : 2.484 GHz
          Channel 32 : 5.16 GHz
          Channel 34 : 5.17 GHz
          Channel 36 : 5.18 GHz
          Channel 38 : 5.19 GHz
          Channel 40 : 5.2 GHz
          Channel 42 : 5.21 GHz
          Channel 44 : 5.22 GHz
          Channel 46 : 5.23 GHz
          Channel 48 : 5.24 GHz
          Channel 50 : 5.25 GHz
          Channel 52 : 5.26 GHz
          Channel 54 : 5.27 GHz
          Channel 56 : 5.28 GHz
          Channel 58 : 5.29 GHz
          Channel 60 : 5.3 GHz
          Channel 62 : 5.31 GHz
          Channel 64 : 5.32 GHz
          Channel 66 : 5.33 GHz

After running sudo iw reg get I get:

    global
country 00: DFS-UNSET
    (2402 - 2472 @ 40), (N/A, 20), (N/A)
    (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
    (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
    (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
    (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
    (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
    (5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
    (57240 - 63720 @ 2160), (N/A, 0), (N/A)

Using the nmcli dev wifi list command I get:

(process:2078): libnm-WARNING **: 20:27:42.549: no object known for /org/freedesktop/NetworkManager/ActiveConnection/1

IN-USE  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY 
8
  • 1
    Are the networks on a 2.4 GHz channel higher than 11?
    – Jeremy31
    Dec 8 '18 at 14:58
  • @Jeremy31 How could I check that? Dec 8 '18 at 15:09
  • A wifi scanner app for the phone?
    – Jeremy31
    Dec 8 '18 at 15:57
  • Yes the channel is 161 Dec 8 '18 at 16:09
  • Please edit your question to show: lspci -nnk | grep 0280 -A3 and also: sudo iwlist chan and also: sudo iw reg get Welcome to Ask Ubuntu.
    – chili555
    Dec 8 '18 at 21:11
5

This will be a partial answer until we uncover more facts.

I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Reboot. Run and post:

sudo iwlist chan

We are confident that channels above 66 will now be available.

1
  • Now all of the wifi networks are visible! Thank you so much! Dec 9 '18 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.