0

I have recently upgraded my system from Ubuntu 16.04 to 18.04 LTS. I have a Lenovo W530 laptop with an NVidia Quadro K1000 graphics set. I have 2 external monitors, one is an older Dell 1900x1200 and a new Acer 27" monitor. The 27" monitor supports 3840x2160 but I prefer to run it at 2560x1440 in portrait mode (rotated right). I normally use KDE.

In 16.04 I could so this using the KDE settings to set the resolution to 2560x1440 and rotation, or I could use the NVidia X server settings to set the same. However under 18.04 in KDE display settings and also in the native Ubuntu display settings the only modes that I see are 3840x2160, 1024x768, and 640x480.

How do I set the intermediate 2560x1440 display mode?

Del

ETA: I think I have partially resolved this. If I reboot my system then use NVidia settings on first boot, I see the extra resolutions. Use that to set the 2560x1440 and do not use the KDE display settings at all. Save the updated xorg.conf file from the NVidia settings and reboot again.

However I tried the same thing with the native Ubuntu Gnome display configuration and once again it doesn't see the extra resolutions, so it's not a KDE specific problem. I managed to install a second partition running Ubuntu 16.04 with exactly the same NVidia driver version (390.77) and confirmed that both the KDE and Ubuntu display configurator see the extra resolutions just fine in 16.04 but not in 18.04.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.