0

I was trying to run Monero-cli one my Ubuntu laptop and it wont let me run the executable file after the start.sh file. It said Permission denied on both the executable and start.sh and I could not find help for problem on google or askubuntu.com.

Log:

 czho@czho-Latitude-D630:/media/czho/ETC/monero-gui-v0.13.0.4$ sh 
./start-gui.sh
./start-gui.sh: 6: ./start-gui.sh: Bad substitution
./start-gui.sh: 7: ./start-gui.sh: ./monero-wallet-gui: Permission 
denied

czho@czho-Latitude-D630:/media/czho/ETC/monero-gui-v0.13.0.4$ 
./monero-wallet-gui
bash: ./monero-wallet-gui: Permission denied
  • 4
    ... given the /media/czho/ETC/monero-gui-v0.13.0.4 path, I suspect the file is located on external media whose filesystem and/or mount options do not support execution – steeldriver Dec 8 '18 at 2:49
  • as steeldriver said if your miner is on a USB stick get it copied onto your ubuntu drive and execute it from there ... if you then get execute errors you can fix using chmod +x filename1 as Klufy said ... this this make sense – Scott Stensland Dec 8 '18 at 3:23
  • That worked, thx. – CZHO Dec 8 '18 at 6:06
0

As @kulfy and @steeldriver said, move the program into main file system and run

chmod +x FILENAME

and as I said I did not come up with this, @kulfy and @steeldriver did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.