I have to run Ubuntu 14.04 on a MacBook Air 2014. After installing the OS years ago, I remember having to install a wifi driver manually using an ethernet connection. Wifi has worked flawlessly ever since, until today.

After being prompted by System Updater to do a routine kernel update and restart afterwards, my wifi suddenly stopped working.

When I type "wifi on" on the command line, I now get:

wifi      = none (no device)

And the command "sudo modprobe wl" now gives me:

modprobe: FATAL: Module wl not found.

After reading other threads, I tried reinstalling the bcmwl-kernel-source package, to no avail.

For reference, the relevant portion of the output of sudo lspci -v is:

03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)
    Subsystem: Apple Inc. Device 0117
    Flags: bus master, fast devsel, latency 0
    Memory at b0600000 (64-bit, non-prefetchable) [size=32K]
    Memory at b0400000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: [48] Power Management version 3
    Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [68] Vendor Specific Information: Len=44 <?>
    Capabilities: [ac] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Device Serial Number 8c-29-00-ff-ff-00-00-01
    Capabilities: [150] Power Budgeting <?>
    Capabilities: [160] Virtual Channel
    Capabilities: [1b0] Latency Tolerance Reporting
    Capabilities: [220] #15

Thank you for your help


"sudo dpkg -s bcmwl-kernel-source" gives:

Package: bcmwl-kernel-source
Status: install ok installed
Priority: optional
Section: admin
Installed-Size: 7902
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Source: bcmwl
Replaces: bcmwl-modaliases
Depends: dkms, linux-libc-dev, libc6-dev
Conflicts: bcmwl-modaliases
Description: Broadcom 802.11 Linux STA wireless driver source
 This package contains Broadcom 802.11 Linux STA wireless driver
 for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-,
 BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based
Modaliases: wl(pci:v000014E4d00004311sv*sd*bc02sc80i*, pci:v000014E4d00004312sv*sd*bc02sc80i*, pci:v000014E4d00004313sv*sd*bc02sc80i*, pci:v000014E4d00004315sv*sd*bc02sc80i*, pci:v000014E4d00004727sv*sd*bc02sc80i*, pci:v000014E4d00004328sv*sd*bc02sc80i*, pci:v000014E4d00004328sv*sd*bc02sc80i*, pci:v000014E4d00004329sv*sd*bc02sc80i*, pci:v000014E4d0000432asv*sd*bc02sc80i*, pci:v000014E4d0000432bsv*sd*bc02sc80i*, pci:v000014E4d0000432csv*sd*bc02sc80i*, pci:v000014E4d0000432dsv*sd*bc02sc80i*, pci:v000014E4d00004365sv*sd*bc02sc80i*, pci:v000014E4d00004353sv*sd*bc02sc80i*, pci:v000014E4d00004357sv*sd*bc02sc80i*, pci:v000014E4d00004358sv*sd*bc02sc80i*, pci:v000014E4d00004359sv*sd*bc02sc80i*, pci:v000014E4d00004331sv*sd*bc02sc80i*, pci:v000014E4d000043a0sv*sd*bc02sc80i*, pci:v000014E4d000043B1sv*sd*bc02sc80i*)
Original-Maintainer: Alberto Milone <alberto.milone@canonical.com>

"sudo updatedb && locate wl.ko" gives no output.

Second edit:

sebastien:~$ sudo apt-get install --reinstall bcmwl-kernel-source
[sudo] password for sebastien: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded.
Need to get 1,545 kB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
Install these packages without verification? [y/N] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-proposed/restricted bcmwl-kernel-source amd64 [1,545 kB]
Fetched 1,545 kB in 1s (1,010 kB/s)              
(Reading database ... 297568 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~0.1_amd64.deb ...
Removing all DKMS Modules
Unpacking bcmwl-kernel-source ( over ( ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
Building only for 3.13.0-164-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for shim-signed (1.33.1~14.04.3+13-0ubuntu2) ...
Secure Boot not enabled on this system.
Processing triggers for initramfs-tools (0.103ubuntu4.11) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-164-generic
  • "modprobe: FATAL: Module wl not found." Is this after you installed bcmwl-kernel-source? Welcome to Ask Ubuntu.
    – chili555
    Dec 7, 2018 at 20:56
  • Yes. I typed sudo apt-get install —reinstall bcmwl-kernel-source. The reinstallation went normally without errors, but I kept getting this output from modprobe afterwards. Dec 7, 2018 at 21:12
  • Please edit your question to show: sudo dpkg -s bcmwl-kernel-source and also: sudo updatedb && locate wl.ko updatedb takes a few moments; please be patient.
    – chili555
    Dec 7, 2018 at 21:38
  • Done. sudo updatedb && locate wl.ko gives no output Dec 8, 2018 at 12:34
  • You are typing w-lower-case-L and not W-one, correct? It is wl as in WireLess. Very strange.
    – chili555
    Dec 8, 2018 at 15:40

2 Answers 2


Upon investigation, we learned that the driver wouldn't properly compile because the required kernel headers were not installed:

Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. modprobe: FATAL: Module wl not found.

I suggested that you do:

sudo apt-get update
sudo apt-get install linux-headers-generic

And, if there were no errors, then:

sudo apt-get install --reinstall bcmwl-kernel-source

I'm glad it is now working.


After upgrading a ubuntu 14.04 machine the wlan was not working anymore. What worked was a solution I found on Launchpad (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1818134). First, the package shim-signed is removed:

sudo apt remove shim-signed

and then the package bcmwl-kernel-source ist installed again (--reinstall should also work):

sudo apt remove bcmwl-kernel-source
sudo apt install bcmwl-kernel-source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.