I'm trying to install the nvidia driver on an AsRock with a ZOTAC GEFORCE GRAPHICS CARD.

Following these instructions:
Install CUDA 9.0 and cuDNN 7.0 for TensorFlow/PyTorch (GPU) on Ubuntu 16.04

I tried running this:

sudo apt-get install nvidia-384 nvidia-modprobe

The install goes smoothly but I am never able to login to the ubuntu desktop gui after doing so. It just keeps asking me for my password over and over again.

I've tried shutting down X with Ctrl+Alt+F1

sudo service lightdm stop
sudo init 3
sudo apt-get purge nvidia*
sudo apt-get install nvidia-384 nvidia-modprobe

to no avail. I am not able to login to the desktop gui after installing.

I tried installing NVIDIA-Linux-x86_64-367.44.run instead, but get lots of error. I'd like to have that apt-get install work if possible.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.