13

I connected my PC to my TV via HDMI and had to set the default video and audio outputs to the TV, everything worked fine, but after I disconnected, the video playback speed was at 0.5x and the audio was not working. I don't really remeber how I fixed the video playback speed, just that it was pretty simple, but the audio never worked again.

I've tried the answers provided in these questions:

But none was able to get my audio back working.

Audio via bluetooth devices works fine. Please help, I'm new to Ubuntu, and Linux in general, and this is starting to get really annoying.

0

5 Answers 5

33

Similar instance of problem here on a v18.04 box; alsa output works, but pulse is just Dummy Ouput.

This seems to bring back pulseaudio without rebooting. First close any programs using pulseaudio, then as a regular user run:

pulseaudio --kill; sleep 2s; sudo alsa force-reload ; pulseaudio --start

Then play a sound file.

11
  • 1
    It helped me ubuntu 18.04
    – lovalim
    Commented Feb 15, 2019 at 5:10
  • Also helped on Ubuntu 18.10
    – Odysseas
    Commented May 30, 2019 at 20:04
  • Thanks it helped.
    – lovalim
    Commented Jul 19, 2019 at 11:49
  • Worked, and I didn't even have to close all programs using pulseaudio. Commented Sep 11, 2019 at 11:40
  • 1
    This worked for me in 20.04
    – Pedro Rolo
    Commented Apr 25, 2020 at 15:50
3

I have a similar problem on a Dell XPS-13-9350 running Ubuntu 18.04.3 LTS. I've updated to the most recent released Linux kernel.

After a reboot, the system does not detect my sound card, and shows "Dummy Output" as the sound output, and I have no sound of any kind. But, then in a terminal window I run:

pactl load-module module-detect

Settings → Sound then shows "Built-in Audio Analog Stereo" as the sound output and all sound works fine until I reboot again. I have to run the pactl command every time after a reboot.

1
  • Thanx... this command worked for me (Ubuntu 20.04 on dell vostro 2520).
    – Deepak
    Commented May 9, 2020 at 11:07
2

Add this follow lines to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=generic
options snd-hda-intel dmic_detect=0

Then reboot the system

2
  • This is the only answer that worked for me. Commented Feb 15, 2021 at 9:48
  • I have a Dell Latitude 3410 with Ubuntu 18.04 (that came with it), and saw this problem after the first kernel update. The second line in the answer helped me fix sound. I'm not sure modifying alsa-base.conf is that good an idea, because it's part of the alsa-base package, and a later update might come with an updated config file. You can add the interesting lines in a new file in /etc/modprobe.d, then you don't need to worry if updates might overwrite your changes (or that you might be missing configuration updates). Commented Jul 28, 2022 at 19:37
0

I had the same problem with Asus PRIME H310M-R R2.0 motherboard. MattB, your solution solved my problem too, thank you. So I added it to end of PulseAudio configuration file:

echo "load-module module-detect" | sudo tee -a /etc/pulse/default.pa

Now you don't have to run it each time after reboot.

2
  • I was just looking at my /etc/pulse/default.pa file, and it already contains the "load-module module-detect" command but its wrapped in ".ifexists module-udev-detect.so; load-module module-udev-detect; .else load-module module-detect; .endif
    – MattB
    Commented May 10, 2020 at 17:08
  • As I remember my config file also had this line but somewhere in the middle and maybe also wrapped in some if sentence. I just added it in the end and sound started working. It solved my problem so I skipped going deeper into details.
    – st0at
    Commented May 11, 2020 at 18:13
0

Maybe It's Bad Kernel

  • run uname -a in a terminal and it shows 4.15.0-177-generic, then you have the bad kernel version.

Reboot and get into your grub menu and select any version prior to 4.15.0-177. I selected 4.15.0.176 and audio, wifi, and Bluetooth are all back on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .