I'm an absolute newby for Linux / Ubuntu. Yesterday I installed Ubuntu 11.10 on an old computer. It seemed to work fine. However today when I started the computer again the software center had disappeared!!

It wasn't in my starter list. When I used the Dash button it wasn't in my application list.

In the Dash center you can also look to applications ready to download and there it was, the software center. But how do I download the software center without software center?

Double clicking, right clicking, nothing seems to work.

How can I get back the software center, and how do I prevent it from disappearing in the future?

7 Answers 7


Just run the following command in a terminal (commonly reachable via Ctrl+Alt+T):

sudo apt-get install software-center

The above command will install software-center in your computer. If it ever gets uninstalled or "disappears", you can run the command again to install it.

  • what if the software center is already installed? isn't purge recommended to do first? (or just remove it. )
    – Alvar
    Mar 4, 2012 at 15:33
  • 2
    it took my quite a while to find the terminal, but typing in the solution in works. It feels a bit back to the eighties, when I worked a lot with DOS. THX
    – Ruud
    Mar 4, 2012 at 16:35
  • 1
    To quickly access the terminal, press CTRL + Alt + T.
    – James
    Mar 4, 2012 at 16:40
  • Weird that the package is not named anything searchable with "Ubuntu" or "Store". It also doesn't install it when you click an app to install in the dash (it just does nothing). Has anyone filed a bug report?
    – NoBugs
    Feb 7, 2014 at 21:13
  • why it must be disapreared in the first place!
    – Ahmad
    Oct 12, 2019 at 16:09

I had this problem when I recently upgraded Ubuntu Studio 16.10 to 17.04. I fixed the issue this way. Hopefully it will help the OP, or if it doesn't work with 11.10, I hope it helps anyone else having this issue, and found their way here.

First run the usual update.

sudo apt-get update

Then the next step is only if the software-center version didn't work.

sudo apt-get install ubuntu-software

This should work.

To open it from the terminal is straightforward.


Try this worked for me sudo apt install gnome-software


The answer given above does work: sudo apt-get install software-center repairs this. However, the questioner asks: how can one avoid this issue in the future?

It seems that during installation process, the Software Center may actually uninstall itself -- without giving a clear warning about this. This, then, is a challenge for a future Ubuntu -- that the Software Center is able to give a clear indication whenever key software is about being uninstalled. Here is an example of how it can happen, and by being aware of this issue, one may avoid it. It applies to Ubuntu 64-bit 13.10, at least, and I haven't seen the same for Ubuntu 32-bit.

When you start Wine in Ubuntu 64-bit 13.10, it complains about lack of a proper p11-kit. If you use the Ubuntu Software Center to find a different p11-kit, more suitable for Wine, and install this, out goes the standard p11-kit that it seems that the Ubuntu Software Center itself is using. Thereby, for consistency, the Ubuntu Software Center efficiently uninstalls itself. By re-installing the Ubuntu Software Center, it will switch back the p11-kit. (This is something that only arises if you click on 'Show technical items' and click ahead eagerly.)

But the fact that askubuntu.com can search up and answer this question so readily when I needed it shows that askubuntu.com is working really well! :-) Aristo T.

  • 1
    Right. p11-kit is the culprit. Have you submitted a bug report?
    – NoBugs
    Feb 7, 2014 at 21:15

First, search for Ubuntu Software in the Dash.

If you found it, just drag it to the dock (or starter list ;) )

If Software Center doesn't appears, then open the Terminal program, searching in the Dash, and type sudo apt-get install software-center. Press Enter. Type your password (it won't appear anything while you type!), press Enter, press Y when asked and Enter again. When the installer finishes, search again in the Dash, and drop the icon to the Dock.


I had the same problem in 14.04 LTS (Wubi install): I removed the Ubuntu Software Center icon out of the Classicmenu Indicator, and the Software Center disappeared from the starter. All the configuration data still were in my personal file. Reinstalling it, and draging the icon back to the dock helped for one session, and after a restart it was gone again.

All answers here in Ask Ubuntu I checked out did not help, even the ones here at https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure so thanks to Wubi install I saved all my settings and reinstalled 12.04.05 and upgraded to 14.04 again immediately, hoping this would not happen again.


Press alt+f2, enter software-center %u and run this execute this command.

  • 1
    -1 because this doesn't answer the question. OP had mentioned that "It wasn't in my starter list. When I used the Dash button it wasn't in my application list." How can one run the software center as suggested by this answer, if it was not installed first?
    – user37165
    Jan 15, 2016 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.