1

Deja Dup keep failing to backup, giving the following error message:

Failed to read /tmp/duplicity-rrKaLL-tempdir/mktemp-Xw6o6E-1: (<type 'exceptions.IOError'>, IOError('Not a gzipped file',), <traceback object at 0x2172368>)

The problem remains after deleting ~/.cache/deja-dup and also after restarting.

Is this a known problem? Is there a way to force the backup, other than deleting also the remote repository and starting the backup from scratch?

1
  • forcing the backup may corrupt the data, I wouldn't.....Better to find the problem or use another means of backups
    – Ringtail
    Mar 4, 2012 at 18:16

2 Answers 2

2

That would be the best idea. You could also make a new folder and name it "Backup 2", then go to System Preferences > Backup > Location and change it. If it works, delete the old one and rename this to "Backup", but make sure you update the settings.

0

I solved this by deleting a corrupt duplicity-full-signatures file from my destination storage location.

Here are the steps I performed. I tried steps 1 and 2 first, and they didn't work. But I'm listing them so you know exactly what I did.

  1. Deleted the deja-dup directory from ~/.cache/ (This step may be unnecessary.)
  2. Deleted the Duplicity directory from ~/.cache/ (This step may be unnecessary.)
  3. Identified the signatures file in my storage location that I suspected was corrupt (it was created around the time of my last good backup.) and moved it out of the way.

    mv duplicity-full-signatures.20141101T071402Z.sigtar.gz duplicity-full-signatures.20141101T071402Z.sigtar.gz.bak
    
  4. Ran the duplicity cleanup command against my storage location. For example:

    duplicity cleanup file:///home/mrfoo/backups/
    

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .