After upgrading a workstation from 14.04 LTS to 16.04 LTS, it is unable to connect to the ypserver/NIS. Nothing eventful happened during the upgrade.

Everything is correct as far as the ypbind.conf and nsswitch.conf goes.

The workstation functions fine otherwise, with full view of the network (except the files shared by the server it's supposed to connect with).

The server is running a fully-maintained Ubuntu Server 14.04.5.

When I run:

yptest

It gives me:

Test 1: domainname
Configured domainname is "mycompanydomain"

Test 2: ypbind 
Can't communicate with ypbind

(obviously "mycompanydomain" is just a substitute for the actual domain we use here)

Also, I have also tried a clean (bare metal, different hard drive) 18.04 install on this same hardware (as opposed to just an in-place upgrade) and I am getting the same results. This same machine runs fine on 14.04.5. And it runs 18.04 fine too, except I just can't seem to connect to the server.

Is there something inherently not NIS-friendly about versions 16.04 and 18.04?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.