I am using Ubuntu 18.04 and my internet remains on for some time and then goes off (so basically ping doesn't work and neither does any website load inside the browser). I have to reconnect to the wifi and continue. I am not facing any such issues in Windows 10/my mobile using the same wifi network.

Note : This problem occurred in ubuntu 16.04 LTS as well hence I upgraded to 18.04 , it worked fine for 2 days and then again the problem started occurring. Also, I tried editing /etc/resolv.conf to have nameserver but no effect. Also tried to decipher something from output of :

journalctl /usr/sbin/NetworkManager

but couldnt understand much what is exactly failing. Any help is greatly appreciated.

Edit : 1. Output of

sudo lshw -class network | grep driver

is here : https://pastebin.com/as5gU5te

  1. Output of

    sudo modinfo $DRIVER

is here : https://pastebin.com/YJeuQxtP and I see fwlps:Set to 1 to use FW control power save (default 1) in the output.

  1. I currently cannot see any relevant output from

    journalctl -k

hence will update it with relevant content when error occurs.

Also,if it is due to wifi dongle issue, it doesn't occur when I'm using windows 10, so I think that might not be the issue although I am not exactly sure.

  • 1
    Upload the content to pastebin.com if you think it might be relevant and then others can analyse it. There are a lot of things that it might be, I'd try looking at dmesg when the error occurs (or journalctl -k). My first guess would be power saving on your wifi dongle/card/chip (if when it goes down wifi is accessible from other devices). sudo lshw -class network | grep driver will tell you your driver, and sudo modinfo $DRIVER will give info about it including for example if it has powersave. – pbhj Dec 5 '18 at 20:04
  • 1
    Thanks @pbhj for looking into the issue. I've edited the question with relevant info on pastebin. – mandar Dec 6 '18 at 3:29
  • So now you can set options and see if it works. You could look at Windows devicemanager to find how the options are set there. (There are other things this could be, if the dropouts are regular, and don't affect other devices on the same router/AP, then this to be is most likely.) Backup your /etc/modprobe.d/rtl8723be.conf before you change it. Also, there may be hidden options, so google it! – pbhj Dec 6 '18 at 15:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.