2

I recently upgraded my Ubuntu from 17.10 to 18.10 and I have lost my WiFi adapter drivers I can't see WiFi option in the menu list. I have tried installing drives from repo https://github.com/lwfinger/rtlwifi_new but I guess I have messed my entire network setting. Please help.

WIFI Missing in menu list IMG

6
  • If you followed the tutorial to the latter did you restart your system just incase? – George Udosen Dec 5 '18 at 7:58
  • yes after every process i have restarted the system – Mustafa Taheri Dec 5 '18 at 9:16
  • if you run sudo lsmod | grep -i rtl8723be is it listed? – George Udosen Dec 5 '18 at 9:33
  • Thanx Buddy issue is solved. The problem was with the secure boot option. After disabling secure boot from BIOS WIFI option was visible then I have followed these steps suggested by @Manikandan connectwww.com/… for weak signal problem – Mustafa Taheri Dec 5 '18 at 9:53
  • @GeorgeUdosen just have a question is it good to disable Secure Boot from Bios..? – Mustafa Taheri Dec 5 '18 at 9:54
2

The GitHub repository link for Ubuntu 18.04 and earlier returns 404 Not Found now. It seems it has been removed. On Ubuntu 19.04 and later you don't need to download drivers from GitHub anymore.


18.04 and earlier

Realtek RTL8723BE wireless network adapter has problems managing the antenna in Ubuntu which leads to weak wifi signal problems. To fix it follow these steps.

  1. Disable the Secure Boot option in the UEFI setup utility in order to make the wifi option visible in Ubuntu.

  2. Open the terminal and type:

    iwconfig
    
  3. Note down the wlp number. In this example it's wlp13s0.

  4. Go to this link, download the driver zip file to your desktop, and unzip the archive.

  5. Run these commands from the terminal.

    cd ~/Desktop  
    cd rtlwifi_new-master  
    make  
    sudo make install  
    sudo modprobe -rv rtl8723be  
    sudo modprobe -v rtl8723be ant_sel=2  
    sudo ip link set wlp13s0 up  
    sudo iw dev wlp13s0 scan
    
  6. Run the following command to make the settings permanent.

    echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf 
    
2
0

Use the below instruction for installing rtl8723be driver.

git clone https://github.com/jodhpurlaxman/rtlwifi_new.git cd rtlwifi_new make sudo chmod +x install.sh sudo ./install.sh

Check Signal strength using the below commands.

DEVICE=$(iw dev | grep Interface | cut -d " " -f2) sudo iw dev $DEVICE scan | egrep "SSID|signal|(on"

If the signal for the AP to which you wish to connect is -60 or less, then you have problem. Fix the signal strength by changing the "ant_sel" option(1,2,3,4,5) in install.sh file and re-run sudo ./install.sh command and check signal strength again.

1
  • 1
    According to the README.md instructions at your GitHub link: If your kernel is 4.17 or newer (eoan, focal, and later releases), AND your card is not an RTL8723DE, then you should NOT be using the external driver. The built-in one is the same. The currently supported versions of Ubuntu that this answer applies to are now 16.04 and 18.04. – karel Aug 3 '20 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.