Problem

When opening a thunar directory from an application for example:

  • from firefox in the downloads section you click on 'open with folder'

  • or from thunderbird troubleshooting you click on 'open directory'

... the action is mishandled with opening of the dirctory with an other application.


Solution

Was able to resolve this problem as follow:

  • open thunar with root privilege

  • go to

  • ´/usr/share/applications/´

  • open the file 'defaults.list'

  • save the file as defaults.list.backup-original

  • open again the file 'defaults.list'

  • go to 'inode/directory=' (press [ctrl]+[f], paste 'inode/directory=nautilus-folder-handler.desktop' and hit [enter])

  • change 'inode/directory=nautilus-folder-handler.desktop'

  • change into 'inode/directory=thunar-folder-handler.desktop'

  • save the file and check if it works


Furthermore

Noticed that the file mimeinfo.cahce within the same directory has the line:

  • 'inode/directory=org.gnome.baobab.desktop;Thunar-folder-handler.desktop;'

Did change this line because initially the program baobab was opening instead of the directory within the folder manager.

But it had no effect.

And after selecting a file and choose open 'send to (application)' the action to open a folder didn't open baobab any more but this application. It happend every time when opening a directory from various applications.

So in the end this line was left untouched.


Perhaps somebody

with more knowledge about thunar

can explain thunar working

and can confirm if this solution is good enough.


other threads with similar issue:

https://forum.xfce.org/viewtopic.php?id=4128

https://forum.xfce.org/viewtopic.php?id=3163

https://bugzilla.redhat.com/show_bug.cgi?id=1278845

New contributor
user899958 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Actually the directory '/usr/share/applications/' does not contain the file to edit. The file mentioned is a link of ...

'default.list'

pointing to the located in:

'/etc/gnome/'

Although the method mentioned does edit the right file.


I think thunar and nautilus are written with capital in the command. So, it should be:

'inode/directory=Nautilus-folder-handler.desktop'

or

'inode/directory=Thunar-folder-handler.desktop'


Maybe setting thunar as default manager could help, see:

How to set Thunar as a default file manager?

Maybe this command might help:

'sudo gio mime inode/directory Thunar.desktop'


Also it seems Baobab doesn play nice with file managers, see:

https://forum.manjaro.org/t/disk-usage-analyzer-baobab-r-click-open-folder-not-working/50890


Further more, it seems by removing Baobab from the system gives the default behaviour back and resolves the problem.

But removing an(other) application is not the way to go.


New contributor
user900003 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

user899958 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.