13

I have read through multiple articles giving instruction on how to go from 16.04 to 18.*. None of which appear to be working for me.

When I get to

do-release-upgrade

I get the message

Checking for a new Ubuntu release
Please install all available updates for your release before upgrading.

Currently I have /etc/update-manager/release-upgrades set to normal Setting this to LTS yields the same results.

Additionally this is after running both:

sudo apt update && sudo apt upgrade

Of course if I run

do-release-upgrade -d

I get the message

Upgrades to the development release are only
available from the latest supported release.

This makes sense to me. What am I missing here? Can I go from Ubuntu Server 16.04 to 18.*?

UPDATE

I noticed now when I run

sudo apt update

I get this output

sudo apt-get update
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://download.mono-project.com/repo/debian jessie InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:4 http://ppa.launchpad.net/ermshiperete/monodevelop/ubuntu xenial InRelease
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:8 http://ppa.launchpad.net/iconnor/zoneminder/ubuntu xenial InRelease
Hit:9 http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease
Hit:10 http://ppa.launchpad.net/modriscoll/nzbget/ubuntu xenial InRelease
Get:7 http://download.sonarr.tv/repos/apt/debian master InRelease [13.3 kB]
Err:11 http://shell.ninthgate.se/packages/debian jessie InRelease
  Could not connect to shell.ninthgate.se:80 (195.22.88.165). - connect (111: Connection refused)
Fetched 13.3 kB in 5s (2,532 B/s)
Reading package lists... Done
W: Failed to fetch     http://shell.ninthgate.se/packages/debian/dists/jessie/InRelease  Could not     connect to shell.ninthgate.se:80 (195.22.88.165). - connect (111:     Connection refused)
W: Some index files failed to download. They have been ignored, or old ones used instead.

Running

sudo apt list --upgradable

Yields

Listing... Done
libgdiplus/stable-jessie 5.6-0xamarin5+debian8b1 amd64 [upgradable from: 4.2-1ubuntu1]
N: There are 2 additional versions. Please use the '-a' switch to see them.

I believe this may be whats keeping me from upgrading to 18.*. I am a little stuck at this point.

UPDATE

Was able to get this resolved with the answer that I accepted.

I also had to clean up some repos that were dead. I ran into an issue where I could not connect to security.ubuntu.com as well. To resolve this I did the following:

sudo vi /etc/gai.conf

Uncomment the following line

#
# For sites which prefer IPv4 connections change the last line to
#
precedence ::ffff:0:0/96 100

I was able to finish updating. Now upgrading my distro of Ubuntu

Welcome to Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-43-generic x86_64)
6
  • Just pulling on "Please install all available updates for your release before upgrading".... did you do a sudo apt update and, if necessary, sudo apt upgrade? Dec 4, 2018 at 19:49
  • I did in fact do both of those. Everything is up to date.
    – Martin
    Dec 4, 2018 at 20:57
  • Please edit your question to show us the complete output of do-release-upgrade
    – user535733
    Dec 4, 2018 at 23:02
  • That is the entire output
    – Martin
    Dec 5, 2018 at 4:53
  • Any resolution?
    – Jem
    Dec 19, 2018 at 16:06

3 Answers 3

23

I had the same issue. I did:

sudo apt-get update 
sudo apt-get upgrade -y
sudo apt-get dist-upgrade
sudo do-release-upgrade

Hope this helps!

1
  • Will try this today.
    – Martin
    Dec 20, 2018 at 17:03
11

In case someone is unable to solve this with the accepted answer. I had a third-party-repository with a broken-dependency, which showed up via sudo apt list --upgradable - the package in question did require another package, which was unavailable due to an error of the packager.

I solved it by disabling all third party repositories (as root):

cd /etc/apt/sources.list.d/
for i in *.list; do
  mv $i ${i}.disabled
done

Then cleaned the update state:

apt clean
apt autoclean

and restarted the update process:

do-release-upgrade
2
  • 3
    that did the job!
    – GustavoIP
    Dec 29, 2019 at 16:23
  • Thanks, this worked for me. I had some 3rd party-apps which I was not able to resolve.
    – john mich
    Sep 26, 2021 at 11:40
1

Check if there are packages being kept back with sudo apt-get upgrade -y, they don't always show with other commands. For example:

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
$ sudo apt-get upgrade -y
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  liblwgeom-2.5-0 postgresql-9.6-postgis-2.5 python3-psycopg2
0 to upgrade, 0 to newly install, 0 to remove and 3 not to upgrade.

Then upgrade or remove them. That will remove the Please install all available updates for your release before upgrading. message when doing sudo do-release-upgrade.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .