This question already has an answer here:

Ubuntu noob here. How can I speed up boot of this system?

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character. @53.066s
└─ @53.066s
  └─snapd.seeded.service @37.351s +31ms
    └─snapd.service @30.360s +6.987s
      └─ @29.615s
        └─ @29.615s
          └─snapd.socket @29.539s +75ms
            └─ @29.538s
              └─ @29.497s
                └─systemd-ask-password-wall.path @3.649s
                  └─-.mount @3.630s
                    └─system.slice @3.649s
                      └─-.slice @3.630s

marked as duplicate by N0rbert, guntbert, Zanna, Charles Green, Fabby Dec 5 at 19:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 0 down vote accepted

This should answer your question:

Ubuntu 15.04 network manager causing slow boot

In short you can just disable the service.

systemctl disable NetworkManager-wait-online.service
  • I tried the command.., it reduce the time by a few seconds. Can i reduce it further... all the above mention things still take a lot of time – Hamza Saeed Dec 4 at 14:04
  • Please post the new output of the systemd-analyze critical-chain to see how it changed – David Aubin Dec 4 at 14:06
  • updated ^, sorry noob here, don't know the edit code protocols yet... – Hamza Saeed Dec 4 at 14:09
  • Try disabling the winbind service if you don't need it [winbind service'(…) Specifically systemctl disable smbd nmbd winbind – David Aubin Dec 4 at 14:14
  • 1
    Here we're just booting up for speed as that is what you stated as most important. The services the were disabled were all networking related. You can google what each one does specifically as that's outside the scope of the question :) – David Aubin Dec 4 at 17:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.