1

I am using a brand new Dell XPS 13 9370 (developer edition with Ubuntu 18.04) with Dell dock WD15 (which has a RealTek Gigabit ethernet adapter). The wired connection was working on the first day or two after set-up, but now the device is not found and only WiFi is working:

bart@bart:~$ ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 2796  bytes 263389 (263.3 KB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 2796  bytes 263389 (263.3 KB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 10.16.60.2  netmask 255.255.192.0  broadcast 10.16.63.255
    inet6 fe80::66a1:cfc:5a38:e81c  prefixlen 64  scopeid 0x20<link>
    ether 9c:b6:d0:92:e2:47  txqueuelen 1000  (Ethernet)
    RX packets 14541  bytes 9101768 (9.1 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 10748  bytes 1753428 (1.7 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

There are no wired internet settings available in the Ubuntu GUI either, only wireless settings...

bart@bart:~$ sudo lshw -C network
 *-network                 
   description: Wireless interface
   product: QCA6174 802.11ac Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlp2s0
   version: 32
   serial: 9c:b6:d0:92:e2:47
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath10k_pci driverversion=4.15.0-1028-oem firmware=WLAN.RM.4.4.1-00079-QCARMSWPZ-1 ip=10.16.60.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:134 memory:dc000000-dc1fffff

Any help would be greatly appreciated!

  • I finally updated the kernel version from 4.15 to 4.20 and it works normally now. I have other issues but this is another story – SylvainLan Jan 21 at 15:55
  • Thank you for letting me know, and I'm glad that it came in useful for you. I am still on kernel 4.15, so I shall try to update to see if that fixes things for me too. One of the side-effects that I noticed from disabling the ehci_hcd module is a slow start-up time, since ubuntu searches for some driver that it can't find until it times-out... I found a fix for that here: ubuntuforums.org/showthread.php?t=2323253 – Bart Jan 22 at 15:36
  • (the fix is the penultimate post on that page) – Bart Jan 22 at 15:38
0

The solution was to disable ehci_hcd kernel module loading by creating the following file:

bart@bart:/etc/modprobe.d$ cat blacklist-test.conf
blacklist ehci_hcd

I'm not sure exactly why this works, but it fixed my problem.

If anyone could offer an explanation or comments on side effects of this solution, I would be very grateful!

protected by Community Jan 22 at 16:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.