3

Recently I bought a new laptop, ASUS Vivo Book Pro M580GD. The laptop spec. is Core i7 (8750H) 2.2Gz (8th Gen) 16GB RAM with 16GB Optane 1TB HDD Nvidia GTX 1050 4GB Windows 10 Home Pre installed

But I'm Kubuntu lover, The problem is I can't install Kubuntu and any other linux OS to this laptop . When I try to install, the installer will freeze.

I use USB to install kubuntu, I try "quiet splash nomodeset" by pressing "e" key on booting the kubuntu.

I already Followup this tutorial https://peshmerge.io/ubuntu-installation-stuck-on-preparing-to-install-ubuntu-screen/

but, after that installer works, but I can't select the HDD drive on my laptop, it is showing only the USB pen drive as a HDD to install kubuntu.

Can anyone know how to install kubuntu, a laptop like this ??

1

I have the same issue with installing Kubuntu/ubuntu 18.04 on my Asus ZenBook UX434FLC.

In Kubuntu installation, the disk management part skipped with error and in the ubuntu procedure, there is no disk.

After many hours of research, I find a solution that is changing SATA configuration in BIOS to AHCI from Intel RST.

There is a procedure to work Windows with AHCI: https://support.thinkcritical.com/kb/articles/switch-windows-10-from-raid-ide-to-ahci

SSD drives typically perform better using AHCI drivers. There is in fact a way to switch operation from either IDE / RAID to AHCI within Windows 10 without having to reinstall. Here are the steps:

  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal (ALT: bcdedit /set safeboot minimal)
  • Restart the computer and enter BIOS Setup
  • Change the SATA Operation mode to AHCI from either IDE or RAID
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.