I recognize this answer has been provided multiple times, but I guess I need a little more help than what I have read thus far. I have a hardware RAID1 SSD set (AMD RAID) that I set up successfully on my ASUS (M4A785-M) motherboard. As per my previous post, I cloned my previous hard drive RAID1 set to the SSDs using Clonezilla. I had a few issues, but the migration was successful.

I just got a notification for an update to Ubuntu base. I tried the update but there was not enough space. I have deleted all older version and memtest and it still needs 697K more space. I have never had an issue before that couldn't be solved just by getting rid of older versions, but it appears more space is needed for this newer base version.

I tried to resize using a GParted startup disk, but have had no success. It appears that I cannot extend this partition. I thought I read somewhere that one could move the /boot partition to an unallocated partition and use that as a the new boot partition. If that is the case, I would appreciate knowing exactly how to do that. If that is not the case, I have two mirrored SSDs with a working Ubuntu operating system that cannot be upgraded.

Any advice on how I can resolve this problem without having to reinstall everything I have from scratch would be appreciated. I have included my GParted output. As you can see, I have plenty of unallocated space on the drive.

My Gparted output

  • Try creating a directory /boot2 place your files in that and soft link them into /boot. ln -s /boot2/any_file /boot/any_file – rhubarbdog Dec 4 at 6:32
  • Thanks, I will give it a try. Would I have to link all new Ubuntu versions that same way. Get the update into /boot and copy them over to /boot2 and do the link to keep ample space in /boot open? – user3147955 Dec 4 at 7:14
  • yes. This may not work, but your next solution is probably back everything up, erase your partitions and start again – rhubarbdog Dec 4 at 8:18
  • Manual, temporary solution: APT keeps two kernels installed. When you have checked the newest installed one works correctly, manually remove the older one. This should give you the space to install another. – Melebius Dec 4 at 8:58
  • 1
    Ok, so I backed up my entire system using APTIK, wiped out my RAID1 pair and installed the latest LTS Ubuntu 18.04 version. Then I did a restore. Had to do a little tweaking here and there (a lot actually) to get it back to the same as it was prior to the reinstall but I got there, all in one day.I notice that now there is only one big partition for the entire file system so space for /boot will no longer be a concern. Thanks to all who gave me advice here. I think this was the most comprehensive solution I could do to resolve this issue. – user3147955 Dec 6 at 4:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.