I recently bought ASUS ZenBook 14 UX433FN which came with preloaded Windows 10 Home. I used it for a few days and everything was working perfectly fine. Then I uninstalled Win 10 and installed Ubuntu 18.04 LTS. And I could hear no sound. I tried many things found online but nothing worked. I tried installing 16.04 LTS as well but the same problem showed up. Unlike reported by many it doesn't show dummy output as audio output.What should I do?

  • For anyone else experiencing this issue, if you're not opposed to using Ubuntu 19.04, the kernal is already updated to 5.XX. Sound and NVIDIA graphics work well with this distro on ASUS UX433FN. – Jon Jun 18 '19 at 19:54
  • I upgraded my kernel to 5.2.2 stable version and the sound problem is solved. How to update kernel : click here. NOTE: In kernel 5.2.2 the suspend problem is also solved. – abstract_17 Jul 24 '19 at 18:44

I have an asus zenbook 14 ux433FN. Faced the same issue with Ubuntu 18.04 (it comes with the kernel 4.15). I upgraded to kernel to 4.20 through the "ukuu" utility and the sound/headphones seem to work fine.

Here are the commands that in case you need to update the kernel

  1. Check your kernel version

    uname -r

  2. install ukuu by following this link: https://ubuntoid.com/install-latest-ubuntu-kernel-ukuu/

  3. update the kernel with ukuu

    sudo ukuu --install v4.20

  4. reboot and check your kernel version

Note: I would also like to point out that the suspend function would not work in ubuntu 18.04 for ASUS ZenBook 14 UX433FN. It would eat up all your battery even if you are in suspend mode. The solution to that can be found in the following link: Ubuntu 18.04 - Dell XPS13 9370 no longer suspends on lid close

  • Thanks a lot. In my case kernel v4.20.6 solved the issue. Big relief – user899635 Feb 1 '19 at 5:59

It seems like there is a patch for the linux kernel comming in to fix the problem soon.


So I think the two options you have is wait for the patch to hit mainline kernel, or to replace it yourself (disclaimer, I haven't done that yet myself)


Installing a bios update (available on Asus website) solved the problem for me, without any further modification in Ubuntu.


I had the same problem, but it got fixed automatically on update of the kernel from 5.0.0-23-generic to 5.0.0-31-generic.

Check your kernel using the command:

uname -r

Try reinstalling Alsa and Pulse Audio

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio

and then force reload alsa

sudo alsa force-reload

You may also install PulseAudio Volume Control to control both the volume of hardware devices and of each playback stream separately.

sudo apt-get install pavucontrol
  • Thank you for your comment. I tried implementing your suggestion but it didn't work. I want to add that sound doesn't work for Ubuntu 16.04/ 18.04 and Linux Mint as well. – user899635 Dec 5 '18 at 22:37

Check your kernel version (doesn't work at 4.15 from my experience)

I checked it with version 4.20.6 and it is working for me.

Take a look here for how to upgrade kernel version

  • Hi it has solved the issue. A big relief. Thanks a lot – user899635 Feb 1 '19 at 6:00

I had the same problem when I updated to bios 309. 307 and 308 don't have this issue. It's easy to update or downgrade a bios with the bios utility Asus EZ Flash 3 Utility, just download and drop the unzipped file in your boot-directory (next to the EFI directory).

Bioses can be downloaded here. https://www.asus.com/us/Laptops/ASUS-ZenBook-14-UX433FN/HelpDesk_BIOS/

(I am on kernel 4.19 btw)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.