I ran Windows 10 update and during the process it restarted a few times and on the second time it completely screwed up my Grub boot manager and no nothing is loading up I get this message upon boot.

error : no such partition.
Entering rescue mode...
grub rescue> 

I've had a look through similar posts and nothing is working. I've used the ls command to try and work out which partition is which but with every command i've tried i get the same result

error : unknown filesystem.

when I ran the ls command I got the following result.

grub rescue> ls 
(hd0) (hd0,msdos5) (hd0,msdos3) (hd,msdos2) (hd,msdos1) (hd1) (hd,msdos1)

I'm guessing this is just a quick configuration fix but I have no idea where to go with this and I'm out of ideas.

  • This is easier howtoubuntu.org/… – HattinGokbori87 Dec 3 at 18:45
  • Your are showing msdos partitions, so your Windows 10 install is BIOS/MBR nor the newer UEFI/gpt. And Windows in BIOS mode has a Microsoft feature(bug) that deletes from partition table the logical Linux partitions, since it does not really see them. Partition still exists, but is not in partition table. You can use testdisk or parted rescue to restore partition. You may then need grub repairs. askubuntu.com/questions/654386/… – oldfred Dec 3 at 21:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.