i was away and my server had some updates to do. i apt update && apt upgrade and my machine froze at ssh.

when i got home it was completely frozen so I rebooted it.

i booted into grub and was able to recover with

set root=(hd0,gpt2)
linux /boot/vmlinuz-4.15.0-39-generic root=/dev/sda2
initrd /boot/initrd.img-4.15.0-39-generic

however upon the next reboot i'm back at grub. i've tried sudo update-grub after i boot in but still the same issue

2nd question - I know how to find what the root is (just ls to you find it) from grub, however I just had to guess what my /dev/sdaX was... is there an easy way to find out from grub?

  • Can you update your question with the output from grep 4.15.0-39 /boot/grub/grub.cfg? – WinEunuuchs2Unix Dec 4 at 0:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.