0

I had a adhoc wifi network setup fine but now with Network Manager I can't seem to get it working. I've followed all the tutorials in google (related to new Network Manager) and the GUI even caters for it but no luck. Anyone else succeeded and willing to share their network file? This is my current attempt - doesn't work.

Network is visible in nm-applet and I can try to connect but always fails. syslog says:

**Syslog **

2150 Dec 3 10:17:13 Squid wpa_supplicant[963]: wlp4s0: Trying to associate with SSID 'ADHOC' 2151 Dec 3 10:17:13 Squid wpa_supplicant[963]: wlp4s0: Association request to the driver failed 2152 Dec 3 10:17:13 Squid wpa_supplicant[963]: wlp4s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="ADHOC" auth_failures=3 duration=30 reason=CONN_ FAILED 2153 Dec 3 10:17:19 Squid org.gnome.Shell.desktop[2783]: [6088:6116:1203/101719.744341:ERROR:connection_factory_impl.cc(400)] Failed to connect t o MCS endpoint with error -105 2154 Dec 3 10:17:20 Squid NetworkManager[970]: [1543850240.3027] device (wlp4s0): Activation: (wifi) Ad-Hoc network creation took too lon g, failing activation 2155 Dec 3 10:17:20 Squid NetworkManager[970]: [1543850240.3029] device (wlp4s0): state change: config -> failed (reason 'supplicant-time out', sys-iface-state: 'managed') 2156 Dec 3 10:17:20 Squid NetworkManager[970]: [1543850240.3035] manager: NetworkManager state is now CONNECTED_LOCAL 2157 Dec 3 10:17:20 Squid NetworkManager[970]: [1543850240.3045] device (wlp4s0): Activation: failed for connection 'ADHOC

Network config file I'm currently trying: /etc/NetworkManager/ADHOC

I've also tried with/without security, static IP, and band selection.


[connection] id=ADHOC type=wifi autoconnect=false permissions=

[wifi] mac-address-blacklist= mode=adhoc ssid=ADHOC

[wifi-security] key-mgmt=wpa-psk psk=1234567890

[ipv4] address1=10.42.1.1/24 dns-search= method=shared

  • Did you edit the network settings using nm-connection editor? If you use nm-connection-editor in Ubuntu 18.04 to change the hotspot password and you use the default WPA & WPA2 Personal security, devices may not be able to connect to your hotspot, displaying an authentication / incorrect password error. At least this is how it worked in my case, using Ubuntu 18.04 to create the hotspot and an Android phone to connect to it. If that's the case, try starting over and only edit the file manually. – Logix Dec 5 '18 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.