2

I'm trying to install Ubuntu on a virtual box and I get this error "This kernel requires an x86-64 CPU, but only detected an i686 CPU." When I go to General -> Basic -> Version I do not find any 64 bit options. Also, in Bios menu I don't have all advanced options (UEFI Firmware Options is missing).

VirtualBox.xml:

<?xml version="1.0"?>
<!--
** DO NOT EDIT THIS FILE.
** If you make changes to this file while any VirtualBox related application
** is running, your changes will be overwritten later, without taking effect.
** Use VBoxManage or the VirtualBox Manager GUI to make changes.
-->
<VirtualBox xmlns="http://www.virtualbox.org/" version="1.12-windows">
  <Global>
    <ExtraData>
      <ExtraDataItem name="GUI/DetailsPageBoxes" value="general,system,preview,display,storage,audio,network,usb,sharedFolders,description"/>
      <ExtraDataItem name="GUI/GroupDefinitions/" value="m=a33345a6-95b1-4c24-b4ee-13625b013b79,m=f790da3a-50f7-444d-9111-aee4bdbb1a79,m=66477e7d-ded9-42fd-9825-fa70fa67a5b9,m=08eb0d4b-5ae3-4285-86dd-d1a77dcd1919"/>
      <ExtraDataItem name="GUI/HideDescriptionForWizards" value="NewVM"/>
      <ExtraDataItem name="GUI/LastItemSelected" value="m=Loredana"/>
      <ExtraDataItem name="GUI/LastWindowPosition" value="319,91,770,550"/>
      <ExtraDataItem name="GUI/RecentFolderCD" value="C:/Users/Loredana/Downloads"/>
      <ExtraDataItem name="GUI/RecentListCD" value="C:\Users\Loredana\Downloads\ubuntu-18.04.1-desktop-amd64.iso,C:\Users\Loredana\Downloads\mini.iso,C:\Users\Loredana\Downloads\ubuntu-18.04.1-desktop-amd64 (1).iso,C:\Users\Loredana\Downloads\ubuntu-16.04.2-desktop-i386.iso,C:\Users\Loredana\Downloads\ubuntu-16.04.2-desktop-amd64.iso"/>
      <ExtraDataItem name="GUI/SplitterSizes" value="255,510"/>
      <ExtraDataItem name="GUI/Toolbar/MachineTools/Order" value="Details"/>
      <ExtraDataItem name="GUI/UpdateCheckCount" value="37"/>
      <ExtraDataItem name="GUI/UpdateDate" value="1 d, 2018-12-04, stable, 5.2.22"/>
    </ExtraData>
    <MachineRegistry>
      <MachineEntry uuid="{a33345a6-95b1-4c24-b4ee-13625b013b79}" src="C:\Users\Loredana\VirtualBox VMs\Ubuntu\Ubuntu.vbox"/>
      <MachineEntry uuid="{f790da3a-50f7-444d-9111-aee4bdbb1a79}" src="C:\Users\Loredana\VirtualBox VMs\lore\lore.vbox"/>
      <MachineEntry uuid="{66477e7d-ded9-42fd-9825-fa70fa67a5b9}" src="C:\Users\Loredana\VirtualBox VMs\Ubuntu-16.04\Ubuntu-16.04.vbox"/>
      <MachineEntry uuid="{08eb0d4b-5ae3-4285-86dd-d1a77dcd1919}" src="C:\Users\Loredana\VirtualBox VMs\Loredana\Loredana.vbox"/>
    </MachineRegistry>
    <NetserviceRegistry>
      <DHCPServers>
        <DHCPServer networkName="HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter" IPAddress="192.168.56.100" networkMask="255.255.255.0" lowerIP="192.168.56.101" upperIP="192.168.56.254" enabled="1"/>
      </DHCPServers>
    </NetserviceRegistry>
    <SystemProperties defaultMachineFolder="C:\Users\Loredana\VirtualBox VMs" defaultHardDiskFormat="VDI" VRDEAuthLibrary="VBoxAuth" webServiceAuthLibrary="VBoxAuth" LogHistoryCount="3" exclusiveHwVirt="false"/>
    <USBDeviceFilters/>
  </Global>
</VirtualBox>

marked as duplicate by karel, Zanna, Eric Carvalho, Charles Green, K7AAY Dec 7 '18 at 22:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Are you running a 64bit version of the virtualbox program? – guiverc Dec 3 '18 at 12:48
  • 1
    +1 gioverc 's command. Please paste your vm configuration. – tai271828 Dec 3 '18 at 13:06
  • 1
    Yes, I'm running a 64bit version of the virtualbox program. – Loredana Coroama Dec 3 '18 at 15:50
0

I think you have one BIOS/UEFI setting to deal with and one misconception about VirtualBox.

First, you will need to be sure that you have virtualization enabled via your BIOS/UEFI menu. For Intel hardware, that is called VT-x. You'll have to see if your motherboard allows you to enable it.

Second is that in general you don't install a guest OS somewhere and then open it up with VirtualBox. The guest OS should be installed in VirtualBox.

So, first let us know if you can set VT-x in your BIOS/UEFI menu and then we'll see about using VirtualBox.

Not the answer you're looking for? Browse other questions tagged or ask your own question.