2

Related to Gedit won't let me change the text size: stuck in giant text mode

I'm using the MATE desktop version of Ubuntu 14.04. If I right click on a text file via the desktop, and choose "Text editor" then it opens in gedit, and all is fine.

However, if I do gedit path/to/file.txt on the command line, then it opens in a "locked down" version of gedit: any changes I make in preferences either refuse to change or switch back to the previous setting immediately.

Doing the "About" option in both reveals them to be the same gedit.

What's the difference between these two things? (desktop vs command line?)

If I could do whatever the desktop does, from the command line, and open files in a gedit where I can change the preferences, that would be ok. Does anyone know how to do that? Thanks.

EDIT - I tried gnome-open path/to/file.txt but that has the same effect as doing gedit path/to/file.txt, ie opening it in a "locked" gedit.

EDIT - as requested:

$ which gedit
/usr/bin/gedit

permissions: I think they're ok...

$ ls -l ~/.config  |grep gedit
drwxrwxr-x  2 max max 4096 Dec  3 10:07 gedit

$ ls -l ~/.config/gedit/
total 8
-rw-rw-r-- 1 max max 4231 Dec  3 10:35 accels
  • 1
    Are you sure that you have correct permissions of ~/.config folder? Also please add output of which gedit to the question. Just curious - why do you use Gedit instead of native MATE application - Pluma? – N0rbert Dec 3 '18 at 10:40
  • I've added some edits thanks. As for "why gedit", I've used it for a very long time and am just used to it really. – Max Williams Dec 3 '18 at 10:46
  • I see your edits, but I can't reproduce "locked gedit" behavior. And as for me Gedit in 14.04 is equal to Pluma (see screenshot) and preferences in Pluma is a bit richer. Could you please add screenshot or some other textual information to make your problem reproducible. – N0rbert Dec 3 '18 at 10:51
  • @N0rbert I've never had this before, either, in any previous linux installs. I've tried removing and reinstalling gedit. I would like to understand the problem rather than just give up and move to Pluma, though I might end up having to do that. thanks – Max Williams Dec 3 '18 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.