I've got a dual boot with Windows 10.

I installed the latest version of Ubuntu today and all went pretty well, rebooted a few times, no problem. Then I opened some of the other partitions/drives and they appeared on my desktop. I tried to delete them but was unable to. Googled how to get rid of them and it said to unmount them, that it wouldn't do any harm. So I did that, and it seems that that caused it to get stuck after the loading/splash screen.

I think I tried to re-mount via Advanced Options in the Grub menu but I have no clue if I did the right thing. I've never used Linux before.

Content of /etc/fstab:

# /etc/fstab: static file system information
# 
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# 
# [file system] [mount point] [type] [options] [dump] [pass]
# / was on /dev/sdb5 during installation
UUID=249483ee-09dc-43d9-956d-a490fb1b5101 / ext4 errors=remount-ro 0 1
# /home was on /dev/sdb7 during installation
UUID=44fc1623-3db6-4a9e-99bb-103c9460565e /home ext4 defaults 0 2
# swap was on /dev/sdb6 during installation
UUID=6cdb970e-de25-42e2-9f07-f3fb442f0d44 none swap sw 0 0

It doesn't actually look like the issue is the partitions. Did a clean install, updated everything, installed Spotify, Discord, Atom and installed Ruby. Rebooted and it freezes all the same. I also added a 1920x1200 screen resolution using xrandr, but that's about everything.

  • Welcome to Ask Ubuntu! :-) Please edit your question and provide the contents of the file /etc/fstab as these partitions probably still get mounted there. if the GUI doesn't work, press [Ctrl][Alt][F1] and log into text mode only and to cat /etc/fstab, then type everything exactly as it is in your question. – Fabby Dec 2 at 23:55
  • Added it in. Might not be very readable but I tried. – M3rein Dec 3 at 0:11
  • Edited for readability, but going to sleep now. Did you delete partition 5, 6 or 7 on your second disk? – Fabby Dec 3 at 0:30
  • It might have been sdb7, /home. I don't quite remember though. – M3rein Dec 3 at 0:35
  • Unfortunately, you don't have enough rep to open a chat room and due some deeper digging. I understood it worked originally without freezing and only froze after you deleted partitions, but now it freezes after the first reboot? Can you still log into the console ([Ctrl][Alt][F1]? – Fabby Dec 3 at 9:33

The issue wasn't related to partitions (at least not that based on what I've found).

My first monitor would originally show at a resolution of 1024x784 or whatever it was, whereas it should be 1920x1200. I applied these settings with xrandr and all was fine, looked the way I wanted it to, and the website I got it from told me to add these lines to ~/.profile using gedit ~/.profile:

xrandr --newmode "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
xrandr --addmode DVI-I-1 "1920x1200_60.00"

But I had sudo in front of the xrandr command. That's what caused it to freeze on startup. Removing the sudo made it automatically switch to this correct resolution upon startup, and also made it work again.

  • +1 for finding the solution yourself. – Fabby Dec 3 at 18:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.