I'm having some trouble in dual boot between Ubuntu and Windows 10.

I've installed Ubuntu in the same disk but using a shrinked partition.

The problem is: My windows (or motherboard, I don't know) is using UEFI mode and there's no option to change this to legacy mode in my bios.

I can select between O.S selecting boot from "Windows boot manager" for Windows, or simple selecting the disk to boot by Ubuntu.

Is there something that I can do to boot by GRUB or something else that I don't need to change "boot disk" every time that I want to change my O.S?

Thank you for your attention.

OBS: I tried to install grub by grub-install or using boot-repair live cd but no success.

Edit: I've installed ubuntu using the partition edit option, because the "install alongside" option didn't appear for me. So I didn't know if grub is already installed or no.

I though that changing to legacy mode, reinstalling ubuntu, the dual boot will work with no issues.

  • Welcome to Ask Ubuntu! There is some context missing here. Are you not able to load grub? Cause if you can, grub should give you the option to boot Ubuntu or Windows. And why would you want to change to legacy mode? What happened exactly when you tried to install grub? You can edit your post to clarify and add details. – wjandrea Dec 2 at 20:43
  • If Windows is UEFI, you do not want to ever boot in legacy mode. That creates more issues. Did you install Ubuntu in BIOS/Legacy/CSM boot mode? If so reboot installer in UEFI mode and run Boot-Repair's advanced mode to toally reinstall grub's UEFI version grub-efi-amd64. – oldfred Dec 2 at 23:30

Looks like your bootloader is on separate partitions.

1) When you burn the iso image to your usb stick for Ubuntu installation, assuming you're using Rufus Tools, make sure you enable both the UEFI and BIOS boot option for your usb stick.

2) When you install Ubuntu, in the partitions page, make sure to install the bootloader on the same partition (or disk) as Windows.

What motherboard did you use? It's strange to hear that you can't switch to legacy mode. If the problem persist, try to burn the USB stick using only UEFI mode or whatever mode you have Windows installed.

  • Just to clarify, make sure to install the bootloader on the disk (e.g. /dev/sda), not the partition (e.g. /dev/sda1). – wjandrea Dec 2 at 21:28
  • Well. I didn't know, but in rufus there's an option to change to GPT partition instead MBR. Now I can see "Install alongside windows" option in Ubuntu installer. But after reboot, I can see the grub window only when I've selected Ubuntu. After trying to boot from Windows boot manager, the grub never appeared to me again. – Bruno Oliniski Dec 3 at 1:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.