I have an iMac configured as follows -

Screen 27" CPU 3.4 GHz i7 Graphics AMD Radeon HD 6970 1024 MB

I downloaded Ubuntu version 11.10 64 bit ISO and burnt that to both DVD and USB stick as per the instructions on Ubuntu's download page.

Neither will boot. Symptoms are as follows -

DVD: When the iMac is restarted and booted from DVD (labelled Windows which isn't mentioned in Ubuntu's website instructions) one line is displayed against a black screen displaying a message about the developer and date. After 5 minutes the message hangs and the DVD ceases to spin.

USB Stick: Strangely I have to select the EFI boot CD icon which appears after holding down the Alt key. A text menu appears offering me to try Ubuntu without installing. I select this and the screen goes blank and stays blank.

Any ideas?

Lastly, after writing Ubuntu to DVD and USB stick, neither could be read by OSX making the instructions to eject them as per Ubuntu website's instructions useless. This might help?

Thanks, Shane.

  • USB install will be very difficult. Also, you should try the ISO specific to Macs (has 'mac' in the name). – Chan-Ho Suh Apr 23 '12 at 0:00


Look into a program called "rEFIt" it changes the boot loader. It's not the best IMO, but it should help you get the job done



I have had similar problems, but was able to get Ubuntu installed. I don't know if it will make a difference, but you may try burning the ubuntu-11.10-desktop-amd64.iso to a CD instead of a DVD. Then start up while holding down the ALT key. When you get to the gray screen which lets you choose the startup disk you can insert the CD at that time (if it isn't already in the CD drive). Then select the one that looks like a CD. If you have two CD icons and one says rEFIt and the other says Windows try Windows once, also.

Don't give up.

I tried with several different versions of Ubuntu and finally got it to install. You can find alternate downloads here. I even got the 32-bit version working on my Mac, too.



Wish I had a solid answer for you, but I have dealt with this problem a few times installing linux on machines from an optical or usb, so I will share what I have to offer...

My suggestion would be to explore and understand how your function keys will affect the boot up process (within BIOS). I have had to deal with many different configurations when installing Linux, and I tend to use a trial and error method when I cant get the proper info through google as far as function keys, and how they affect the bootup.

Just last night I was installing linux on an old averatec netbook, and it took 6 or 7 tries to get it to boot properly.

Throughout the first 6 times i tried, I was presented with the same text you were...

"one line is displayed against a black screen displaying a message about the developer and date. "

if the boot disc loads properly, you should have an option to 'install to disk' as opposed to 'try ubuntu'

another thing you might want to look into is downloading a different version, from the same source or a different source, just to troubleshoot whether or not the version you are trying to run is going to cooperate with you machine.

last bit of advice, try it several times, as there are a few examples where I go through the same process (as a human) - but on the 5th or 6th reboot, things will start to run.

Hope this helps. Good luck, Matt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.