Ubuntu gnome desktop on Ubuntu 18.04 LTS remote VM

This is how my Ubuntu gnome desktop appears like when accessed remotely through VNC viewer. The content appears very blurry and very difficult to read. I have set up this Ubuntu gnome desktop on Ubuntu 18.04 LTS on GCP.

I have tried setting different values with this syntax and also in .vnc/xstartup script:

$ vncserver :1 -geometry 1024x768 -depth 24

But it doesn't seem to work.I have spent 2 days for setting and changing configurations and bash scripts to reach here and rectify this. I really prefer using VMs hosted on Clouds due to fast running applications on their platform unlike our own compute machines hence would really appreciate urgent help over this. This is the only bottleneck remaining to make progress in my work.

The session information for this on VNC viewer shows

size: 1024x768

pixel format: depth 6 (8 bpp) rgb222

My contents of .vnc/xstartup are :

# Uncomment the following two lines for normal desktop:
# exec /etc/X11/xinit/xinitrc
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &
export XDG_CURRENT_DESKTOP="GNOME-Flashback:Unity"  
export XDG_MENU_PREFIX="gnome-flashback-"
#gnome-session --session=gnome-flashback-metacity --disable-acceleration-check --debug &
gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &

Thanks in advance!

Result of the below command is :

$ lspci -nn|grep VGA
00:03.0 Non-VGA unclassified device [0000]: Red Hat, Inc Virtio SCSI [1af4:1004]


$ uname -a
Linux ubuntu-18-04 4.15.0-1024-gcp #25-Ubuntu SMP Wed Oct 24 13:09:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux 

Because you should start session with gnome-session --session... line and not manually starting required applications. For example gnome-settings-daemon has been split in many smaller applications... And I think it is your problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.