My asus laptop is refusing to boot anything from USB as long as a drive is connected to the SATA port on the motherboard.I can boot any USB sticks just fine with no drive connected. This is essentially making it impossible for me to install Ubuntu.

Things I've tried that might be worth knowing: I've three different bootable USB sticks available and have confirmed that all of them are working(Ubuntu Mate, Windows 10, Memtest). I've also set up the boot order and have tried the "force boot" option in the BIOS which just results in a black screen. Secure Boot is disabled. I've tried with two different SSD connected to the board to make sure that the one I'm trying to install onto isn't faulty.

I really hope someone here can help me since I've been struggling with this issue for quite a while now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.