Laptop: Lenovo Legion Y730 15' with Ubuntu 16.04 LTS (64-bit)

Specifications:

  • Processor: Intel® Core™ i7-8750H CPU @ 2.20GHz × 12
  • Graphics: Intel® HD Graphics (Coffeelake 3x8 GT2)
  • Graphics: nVidia GTx 1050ti

Please help - I am at my wit's end. I am new to Ubuntu so I am sure that there is something very simple that I am missing but I cannot seem to figure it out. I cannot seem to get my discrete nvidia GTX 1050ti graphics card to work in 16.04. I recently purchased a Lenovo Legion Y730 laptop that has both an intel graphics card and an nvidia card. No matter what I try, the driver does not seem to be loading/running the card.

I have followed all the instructions I found on this similar post: Cannot get NVIDIA graphics card to work on Ubuntu 18.04

To be specific, I have:

  1. Purged all nvdia
  2. Downloaded the ppa
  3. Installed and tried various drivers including the recommended version
  4. Blacklisted the nouveau drivers
  5. Rebooted
  6. Finally, ensured that secure boot is disabled.

I have tried almost every variation to these steps found in other troubleshooting posts. I have even recently tried a fresh-install to no avail.

I cannot connect to any HDMI monitors (which I desperately need), I cannot even open NVIDIA X Server Settings. When I click on the application, the icon blinks in the side bar then disappears. When I try opening it from the terminal, I get the following:

$nvidia-settings
ERROR: Unable to load info from any available system

Below are some outputs that may be useful for troubleshooting:

$uname -r
4.19.1-041901-generic

$lspci -k |grep -EA2 'VGA|3D'

00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
    Subsystem: Lenovo Device 39fc
    Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation Device 1c8c (rev a1)
    Subsystem: Lenovo Device 39fc
    Kernel modules: nvidiafb, nouveau

$lspci -nnk | grep -i vga -A3
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
    Subsystem: Lenovo Device [17aa:39fc]
    Kernel driver in use: i915
    Kernel modules: i915

$glxinfo|egrep "OpenGL vendor|OpenGL renderer"
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics (Coffeelake 3x8 GT2)

$ sudo lshw -C video 
*-display UNCLAIMED     
       description: 3D controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:62000000-62ffffff memory:50000000-5fffffff memory:60000000-61ffffff ioport:4000(size=128) memory:63000000-6307ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: iomemory:600-5ff iomemory:400-3ff irq:142 memory:6022000000-6022ffffff memory:4000000000-400fffffff ioport:5000(size=64) memory:c0000-dffff

Above it shows that the display for the nvidia card is "unclaimed" but I am not sure how to remedy this. The drivers seem to be downloaded, and when I check additional drivers, it shows that the nvidia driver is in use. Is there anything that I am missing, or any other threads that I have not been able to track down that shows how to solve this?

If any more information is required please let me know.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.