1

After upgrading from Ubuntu 18.04 to 18.10, the user interface of web browsers (Firefox and Chrome) looks too congested. All the webpage's content is squeezed together in a small congested area as shown below in the first 3 screenshots.

Screenshot of Firefox
New Tab in Firefox  (Click images to enlarge)

a webpage opened in Firefox
webpage in Firefox

Screenshot of Chrome
New Tab in Chrome

Increasing the font size doesn't help either. The pages still take same amount of space. The problem started in Ubuntu 18.04 and persisted after I upgraded from Ubuntu 18.04 to Ubuntu 18.10.

For comparison, below is a screenshot of the Firefox New Tab page in Windows 10.

Firefox on windows

Notice the larger icon sizes in the Firefox speed dial area. The difference varies from website to website.

  • 1
    It looks beautiful to me. What's the problem? Is it DPI? – earthmeLon Dec 2 '18 at 1:36
  • See the second screenshot for example, the page isn't taking full page. If I increase the font size, only font size increases, still taking same amount of space. – shreyas Dec 2 '18 at 1:43
  • 1
    Does scrolling your mouse wheel up, while holding Ctrl solve your problem? The browser uses its own fonts and scaling, and these can differ from your system settings. – earthmeLon Dec 2 '18 at 1:52
  • Only in some pages. – shreyas Dec 2 '18 at 1:58
  • 2
    Have you looked at the source code of the ecircuits page? It has "<table border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse" bordercolor="#111111" width="700" id="AutoNumber1">" and "<td width="616" align="left" valign="top">", etc. How does the page display on a Windows machine with a Windows browser? – DK Bose Dec 2 '18 at 3:09
2

The congestion in the web browsers is controlled by the Zoom Settings in both Firefox and Chrome. In Firefox access the Zoom settings by clicking the three horizontal bars Settings icon IMG: in the top right corner -> Zoom -> click ➕ to increase zoom %.

enter image description here

Instead of changing the size of everything, you can just change the size of the text in Firefox. You can also click the Zoom Text Only option iin the below screenshot to remove the checkmark and toggle Zoom Text Only from on to off if it is already selected.

IMG:

  1. Press the Alt key to temporarily bring up the traditional Firefox menus. On the menu bar at the top, click View -> Zoom.
  2. Select Zoom Text Only. This makes the controls only change the size of text, not images.

In Chrome the Zoom can be changed by clicking the three dots icon in the top right corner -> Settings -> Page zoom -> select the default zoom for all pages from the Page zoom dropdown menu. The page zoom for a specific webpage can be changed to override the default zoom settings for all pages by clicking the three dots icon in the top right corner -> Zoom -> click ➕ to increase zoom %.

In Chrome the default font size for all webpages can be changed by clicking the three dots icon in the top right corner -> Settings -> Font size -> select the default font size for all pages from the Font size dropdown menu. If the preset font size options don't look exactly right there is also a Customize fonts option located below the Font size option. Click the ▶ to the right of where it says Customize fonts to access the Customize fonts page.

  • This solution worked on Chrome. It's with Firefox that it didn't work. When I zoom in, only font size increases. All the icons and input bars remain in the original size – shreyas Dec 2 '18 at 6:27
  • I added instructions to my answer to fix this. – karel Dec 2 '18 at 6:30
  • This worked for me :-) – shreyas Dec 2 '18 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.