3

I want to install Linux on "Dream Machines" notebook based on Clevo mainboard. It's worth mentioning that it has a discrete NVidia GPU.

The problem is that during each attempt to install I randomly face to freezing screens during installation. Even when I was able to proceed installation process and install Linux, I get the same freeze after I pass Log In. Those freezes are similar among all of those Linux Distributions.

Linux Mint Before and After Log In

enter image description here enter image description here

HAVE TRIED:

  1. Different Linux Ubuntu based Distributions: Ubuntu (16.04.5 / 18.04.1 / 18.10), GnomeUbuntu (16.04.5), Xubuntu (18.04.1), Mint(18.04.1)
  2. Different Linux User Interfaces based on those Linux DE: (Gnome, XCFE, Cinnamon, Unity)
  3. Different kernel version which were included in those Linux DE versions up to the last release kernel version 4.18 in 18.10.1
  4. 2 Different flash drives (I did bootable USB flash drives with Etcher as suggested in Ubuntu documentation for MacOS.)
  5. 3 Different Ports (USB3.0-USB2.0)
  6. GRUB editing in EFI mode before installation as was suggested by Blanka V. 1 - Tried adding acpi=off after quiet splash. 2 - Tried nomodeset instead of quiet splash before installation but it didn't help either.

I have also tried to execute Terminal via CTRL+ALT+F1 or CTRL+ALT+T, but it immediately freezes as well, so I cannot manually get into Terminal.

My problem is kinda similar as written here and I always have no idea what happens.
P.S: It's not duplicated from this question.

Can someone please help and guide me what I should do and what the reason of the error can be?

SUGGESTIONS:

  1. As was suggested by @manowar_manowar the problem can be related to the Clevo mainboard. And installation via nomodeset gives me a successful installation process without freezing but anyway I cannot go further after Log In. The solution can be is to update kernel to 4.19 version and install/activate lightdm but how to do it if in Normal session I have no ability to open Terminal without freezing as was written above. Are there any magic combinations to open Terminal without freezing except those are written above?
  2. I clearly described what was wrong with installation and sent message to Dream Machines. The reply:

Hi,

Our notebooks do not support Linux officially, altough we work on Ubuntu in our office. Your problem is most likely with GPU drivers, you need to search on the internet how to install Nvidia GPU drivers via the recovery (connection to the internet via LAN may be required as wireless card won't work in recovery).

Best regards, Dream Machines

  • I have a notebook like yours. Clevo mainboard. I installed ubuntu 18. I have same problem . But when i try nomodeset , installation was successful with 1-2 freeze . After that , you should install kernel 4.19 and lightdm. Freeze problem now finished. – manowar_manowar Dec 1 '18 at 21:15
  • @manowar_manowar Thanks a lot for suggestion, May you explain how can I install kernel 4.19 and lightdm if I cannot open Terminal with combination I wrote above? How was you able to do it? It seems like I cannot install Linux at all :). BTW, I've searched and found that the last version of Ubuntu 18.10 is based on the Linux kernel release series 4.18. But as you say 4.19 is needed. wiki.ubuntu.com/CosmicCuttlefish/ReleaseNotes . I have to solve this problem and edit this question with additional info because this is just insane I want nobody will ever experience such a problem. – Ivan Shelonik Dec 2 '18 at 8:16
  • Hi Ivan. If your computer freeze please try some grub bootloader options. Try nomodeset , noapic and others . Plus disable secure boot in bios.I remember , i started linux with usb with some grub options and i saw desktop setup icon and install ubuntu. If your install finished, you can find 4.19 kernel in google. It redirect to you ubuntu kernel archive. And you can download and install from 4 deb files. Plus you should install lightdm. You can wite command line "sudo apt install lightdm" . After it ask you default desktop manager. You must select lightdm. – manowar_manowar Dec 2 '18 at 17:29
  • If your installation is successful ( i read it) , dont go login screen. 1. You can start linux with recovery mode with network connected (Grub). 2. Another option : You can start linux nomodeset again (if possible) or another grub options. And you can try install and remove something. – manowar_manowar Dec 2 '18 at 18:41
  • 1
    @manowar_manowar Thanks a lot for the help. :) I got more new things from you. Now you can read the answer that helped me) But anyway thanks! – Ivan Shelonik Dec 7 '18 at 19:46
0

SOLUTIONS:

I got into recovery mode. Then installed 4 debs files for 4.19 Kernel from this site and at the end installed/activated lightdm

uname -mrs diplsays me that kernel was upgraded to

4.19.0-041900-generic x86_64

now doing sudo reboot and observe what happens

So, all steps which were given by @manowar_manowar were completely and successfully done. Unfortunately It didn't help

Then I tried to update NVidie GPU drivers with current long-lived branch release: as was suggested by Dream Machines Team

sudo add-apt-repository ppa:graphics-drivers/ppa 
sudo apt install nvidia-396
sudo reboot

after 3 days of installation process I was able to get it work Believe my issue will help someone.

enter image description here

  • 1
    Hi Ivan. My another solution is , Menu->Software&Updates->Additional drivers->Select (xorg driver) – manowar_manowar Dec 8 '18 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.