1

I have been trying to install cuda, and I cannot for the life of me figure this out :(. This is the error that i keep running into, and I can't think of any packages that would be broken on this machine. It's a fresh install of Ubuntu Server (uname -a Linux marte 4.18.0-11-generic #12-Ubuntu SMP Tue Oct 23 19:22:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux running Cosmic)

% sudo apt-get install cuda
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-10-0 (>= 10.0.130) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Some other possibly useful information?

My attempt to find any broken packages

% sudo debsums --changed
sudo debsums --changed  7.72s user 3.54s system 22% cpu 49.658 total

/etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu cosmic main universe
deb http://archive.ubuntu.com/ubuntu cosmic-security main universe
deb http://archive.ubuntu.com/ubuntu cosmic-updates main universe

Edit: Going down the rabbit whole to try and install unmet dependencies manually, I have come to the following wall

The following packages have unmet dependencies:
 nvidia-410 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23 but it is not installable
              Recommends: nvidia-settings (>= 331.20) but it is not going to be installed
              Recommends: nvidia-prime (>= 0.5) but it is not going to be installed or
                          bumblebee but it is not going to be installed

Does anyone have any suggestions?

  • In apt-speak, dependency problems are what 'broken' actually means. Look for wrong-version sources that cause the impossible situation. For example, the error message is saying that the non-Ubuntu-package cuda-10-0 cannot be installed due to dependency problems. – user535733 Nov 30 '18 at 23:19
  • @user535733 That was what I originally thought! So going down the rabbit whole, I was met with an error that I'm not entirely sure how to deal with, I've updated the original post to reflect these "findings". As per the edit, should I be looking in a non-ubuntu repo for this? Im not sure what is not installable means (outside of not able to be installed :'D) – j-money Nov 30 '18 at 23:30
  • 1
    Server does not even have X, so while I have seen the cuda executables run the non-graphical samples under Wayland, how are you planning on running cuda? – ubfan1 Nov 30 '18 at 23:35
  • I swear one day i'll learn how to post @ubfan1 This was another thought I had, so I tried installing X. Are your thoughts that I should scrap it (It really is just a fresh install with X, and zsh installed) and install ubuntu desktop? – j-money Nov 30 '18 at 23:38
  • Might as well, if you need to install X on a server, desktop is probably the way to go. Get the Nvidia drivers set up from the ubuntu repos, and then do the CUDA deb from Nvidia. Not sure what cuda you'd need from the ubuntu repos after that, maybe nothing. – ubfan1 Nov 30 '18 at 23:45
2

the problem is that ubuntu does not know where to find these packages. type the following code in terminal:

add-apt-repository ppa:graphics-drivers/ppa
  • 2
    Please go back and re-read the question this is not a solution to the problem, I have already provided my solution in one of the edits, – j-money Feb 21 at 8:02
  • 1
    @j-money Consider to write into a proper answer instead of edit within the question itself. Yes, you can and encouraged to self-answer. – clearkimura Feb 21 at 8:22
  • @j-money if the problem is "cuda has unmet dependencies", i think my solution works also, and it is an easier one – jiang xu Feb 21 at 9:50
  • 1
    @j-money It is OK to post a new answer to an already solved question! It might be useful for other users running in the same situation. You are not forced to accept or upvote the new answer. – Melebius Feb 21 at 11:23
  • 3
    @j-money Watch your tone. And please don't give bad advice. Timestamps are absolutely irrelevant here, answers are always welcome even on older posts. And answers that can help other users with the same (or similar) problem are also welcome. Granted, this isn't helpful for you, but that's no reason to be rude. – terdon Feb 21 at 13:29
2

The package that provides xorg-vide-abi-* was xserver-xorg-core(2:1.19.6-ubuntu4.2) but the held package was xserver-xorg-core(2:1.20*) and no longer provided the xerver-xorg-core package necessary

So downgrading said package worked, and ignoring said package (sudo apt-mark hold xserver-xorg-core) when upgrading did the trick

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.